No. Adjust height to fit zone. - Do not work for images / imageslider.

Problem: I've inserted imageslider into a web part, and using the property "no. Adjust height to fit zone". But the images do not resize correctly in each web part. Each picture takes more space than what I set to the current zone.


              <td class="middleWebPartZoneTD2 fullWidth wpTitleBorderBox greyTitleWebPart" valign="top" style="padding: 0">
                <table class="tableTRfullWidth" cellpadding="4" cellspacing="0" border="0" width="100%" height="100%">
                        <td class="zone1 middleImageSlider" Width="60%" name="_invisibleIfEmpty" valign="top" height="100%">
                            <WebPartPages:WebPartZone runat="server" Title="ImageSlider" ID="middleImageSlider" FrameType="TitleBarOnly">
                        <td class="zone2 middleImages" Width="35%" name="_invisibleIfEmpty" valign="top" height="100%">
                            <WebPartPages:WebPartZone runat="server" Title="MiddleImages" ID="middleImages" FrameType="TitleBarOnly">

I've tried to set width directly to the web part..

  • What ImageSlider are we talking about, content search webpart display template ? Commented Feb 26, 2014 at 14:56
  • No the standard one..
    – Plexus81
    Commented Feb 26, 2014 at 15:01
  • I wasn't aware of another image slider option in SP 2013 other than display templates on search related WP's. Of these implementations, I know that they do not care about your webpart zone's width/height. In a similar situation I had to resize them in the display template itself. Commented Feb 26, 2014 at 15:04

1 Answer 1


While it is not likely the answer that everyone would like to use, resize the images themselves to the appropriate size before uploading . Making SP do the work increases overhead and can cause lag in addition to issues with correct sizing and appearance on the site. Relying on a program to make changes on the fly is not a good idea. It is far better both from a SA perspective and a UX perspective to make sure your images are correctly sized to begin with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.