1

I keep on getting:

Sorry, Something went wrong.

Correlation ID: 00000000-0000-0000-0000-000000000000 

in my Content Search Webpart. The Content Search Webpart is configured to get results limited by a Custom Content Type (Custom Page Contenttype) and a Custom Display Template (does some JavaScript for Image Rendering). Sometimes the CorrelationID 000.. showes up, and sometimes not. When I press Strg+F5 it works most of the time. I have also seen this article and tried the following code:

$myfarm = Get-SPFarm
$myfarm.XsltTransformTimeOut
$myfarm.XsltTransformTimeOut = 15
$myfarm.Update()

Even I tried it with 15 seconds but I haven't seen any effect. Does anyone know the reason why this happens or can give me a soloution for this fault?

EDIT_1

Here is the report. I couldn't find state: Degrade but I did a Index-Reset and a Full Crawl anyway because it is just a developement machine and mabey it helps. And testing it for a while, i came to the decision it could have helped. I didn't recieve the sorry something went wrong dialog in the last hour. If I don't recieve it in the next month again, I'll accepet your answer. Thank you for your response.

Report:

> Get-SPEnterpriseSearchServiceApplication | Get-SPEnter
priseSearchStatus -Text
Name      : IndexComponent1
State     : Active
Primary   : True
Partition : 0
Host      : sepp0019

Name      : Cell:IndexComponent1-SP18556ba382adI.0.0
State     : Active
Primary   : True
Partition : 0

Name  : Partition:0
State : Active

Name  : AdminComponent1
State : Active
Host  : sepp0019

Name  : QueryProcessingComponent1
State : Active
Host  : sepp0019

Name  : ContentProcessingComponent1
State : Active
Host  : sepp0019

Name  : AnalyticsProcessingComponent1
State : Active
Host  : sepp0019

Name  : CrawlComponent0
State : Active
Host  : SEPP0019

EDIT_2

Today I finished the updates you suggested. I'm not sure if it helped but it seems to work now. I'll let you know when I am sure that the problem doesn't occour again. Thank you very much for the immediate answers.

  • Does the CSWP use XSLT to manipulate the results? I don't think it does. – iOnline247 Oct 29 '13 at 15:21
  • No, I don't use XSLT. Just a little bit of JavaScript and CSS to display the results in a way like Bootstraps "Carousel". – Franz Oct 29 '13 at 16:07
  • I was pointing out why XsltTransformTimeOut didn't work for you. – iOnline247 Oct 29 '13 at 22:56
0
  1. Make sure that you have installed the current software update for SharePoint.

  2. Check your current timeout settings, simply use the following PowerShell:

 $myfarm = Get-SPFarm> 
 $myfarm.XsltTransformTimeOut
 $myfarm.XsltTransformTimeOut = 5
 $myfarm.Update()

If you’re experiencing the above problem, you probably got a 1 back from the above command indicating that the timeout is currently set to 1 second. To set it to a more reasonable value (we choose the original 5 seconds) just do this (assuming you set the $myfarm object using the above powershell):

http://social.technet.microsoft.com/Forums/sharepoint/en-US/f7b8a70e-5663-4532-9327-3c15da58cfca/correlation-id-00000000000000000000000000000000-error-in-content-search-sometimes?forum=sharepointadmin

EDIT

goto powershell and do the following:

Get-SPEnterpriseSearchServiceApplication | Get-SPEnterpriseSearchStatus -Text

http://technet.microsoft.com/en-us/library/jj219672.aspx

can you post back within your question the result? do you see state : Degraded within the report? if so reset the search index:

To reset the content index

1.Verify that the user account that is performing this procedure is a service application administrator for the Search service application for which you want to reset the content index.

2.On the SharePoint Central Administration home page, in the Application Management section, click Manage service applications.

3.On the Manage Search Applications page, click the Search service application for which you want to reset the content index.

4.On the Search Service Application: Search Administration page, in the Quick Launch, in the Crawling section, click Index Reset.

5.On the Search Service Application: Index Reset page, verify that the Deactivate search alerts during reset check box is checked, and then click Reset Now.

6.In the confirmation dialog box that appears, click OK to confirm the content index reset.

The Search Service Application: Search Administration page opens and the System Status is displayed.

7.Perform a full crawl.

enter image description here

http://technet.microsoft.com/en-us/library/ff608191(v=office.14).aspx

EDIT

I need to know if you have updated sharepoint since you downloaded it? as this sounds like a bug that is fixed with the current updates released:

update your server with the following updates that should resolve this issue as the above method should of worked:

http://support.microsoft.com/kb/2767999

and then do this:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;2726992

You must do the first link first before you do the second as the second update is reliant on the first update!

  • Thank you for your answer, but as you can see in my Question i already tried it with 15 seconds. And still get this message. – Franz Oct 29 '13 at 14:29
  • just ammended my answer, should hopefully get your search working again! – Ali Jafer Oct 29 '13 at 14:49
  • Just edited my Question, the dialog didn't show up in the last hour, since i made a index reset and a full crawl. Mabey this realy helped. But I once tried this, but the message came again. If it doesn't show up the next month, I'll mark your answer as accepted. Thank you verry much! – Franz Oct 29 '13 at 16:05
  • no probs! sounds like it didnt index in the first place but lets hope that it sticks this time ;) the state is active now what is a good sign! next time you get into the same error just print out the text report to check! – Ali Jafer Oct 29 '13 at 16:09
  • Happend again.. Report showes everything is still active: – Franz Oct 30 '13 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.