2

We have SharePoint installed on our 2008 SBS server and I can access this using my desktop from address http://companyweb which redirects to http://companyweb/default.aspx and works fine. However, when I type "http://companyweb" on my android device it searches the internet. If I type http://companyweb.domain.local the default IIS7 homepage is displayed. How can i get the login to sharepoint on my android device?

I wasn't sure whether to post this here or Android but I thought the solution might be getting the correct SharePoint URL. Please forward me to a more appropriate place if you feel this is right.

Thanks

  • Internet works. It might be a dns issue. How do i get SharePoints full URL? i know the ip address of the server, what would i type after that to access the sharepoint server address? – resolver101 Oct 29 '13 at 12:13
  • I think I've realized the problem now. Apple and Windows desktop both use my companies DNS suffix (domain.local) and android doesn't. If I use the FQDN (fully qualified domain name) Windows servers IIS doesn't redirect to SharePoint. How can I find the full path for sharepoint on my server? – resolver101 Oct 29 '13 at 13:24
2

Mobile browser redirection To access a site using the optimized mobile browser experience, a new feature named Mobile Browser Viewer must be activated on the site. If activated, this feature checks the device’s mobile browser to determine if it can handle HTML5. If the mobile browser supports HTML5 the contemporary view is shown. Otherwise, the classic view is shown.

By default, this feature is activated when any of the following site templates are used:

Collaboration templates Team Site, Blank Site, Document Workspace, Blog, Group Work Site, Visio Process Repository

Meetings templates Basic Meeting Workspace, Blank Meeting Workspace, Decision Meeting Workspace, Social Meeting Workspace, Multipage Meeting Workspace

Enterprise templates Document Center, Records Center, Business Intelligence Center, My Site Host, Basic Search Center, FAST Search Center

All other site templates require you to explicitly activate the feature. You can activate or deactivate Mobile Browser Viewer in Site Settings under Site Actions and Manage Site Features.

http://office.microsoft.com/en-gb/office365-sharepoint-online-small-business-help/use-a-mobile-device-to-work-with-sharepoint-online-sites-HA102891452.aspx#_Toc351995396

a more detailed info on the redirection feature follow:

legacy MobileRedirection feature

http://msdn.microsoft.com/en-us/library/office/ms462572(v=office.14).aspx

EDIT

Your right android uses FQDN and not dns suffix hence why your getting the login issue,

https://android.stackexchange.com/questions/20419/how-can-i-enable-dns-suffix-support-on-android-resolv-conf-search

I think this becomes more of an android issue rather than a sharepoint issue

Does anybody know if there is any workaround on this? (without having to root the device). Is there any way to configure the device or browser to always interpret or modify a given address to its FQDN form? I use Sharepoint, and I can use the FQDN address with no problem, but as soon as the server redirect me, the browser stop finding the server.

http://code.google.com/p/android/issues/detail?id=8030

you could try this, you need to add alternate access mapping for fdqn as android has no dns suffix

By default, a new SharePoint Server 2013 deployment enables access through the NetBIOS name (e.g., savdalsps01) and not its FQDN (e.g., savdalsps01.savilltech.net). To solve the problem, an Alternate Access Mapping must be added for the FQDN.

1.Navigate to the SharePoint Server 2013 Central Administration site (e.g., http://:6999, e.g., http://savdalsps01:6999).

2.Select System Settings from the navigation pane.

3.Under Farm Management, select the Configure alternate access mappings.

4.Under Alternate Access Mapping Collection, select Change Alternate Access Mapping Collection.

5.Select name of SharePoint - 80.

6.Click the Add Internal URLs link.

7.Type the FQDN http://<FQDN>:80 (e.g., http://savdalsps01.savilltech.net:80) and select the Intranet Zone from the drop down and select Save.

i know its for 2013 but is same for 2010

http://windowsitpro.com/sharepoint-2013/enable-fqdn-access-sharepoint-2013

  • The article says to type in the URL. My problem is the url from android isn't working. How can i get the url to work? – resolver101 Oct 29 '13 at 12:15
  • @resolver101: do you mean you can't edit / alter the URL in your mobile browser? – TempaC Oct 29 '13 at 12:49
  • no i mean. Why does the url work from desktop and iphone but not from android. I want it to work from android. – resolver101 Oct 29 '13 at 12:57
  • @resolver101 androdi blocks sharpeoint popup for some reason to login, try this, goto android app store and download the firefox browser app and access site from there! it should work fine! – Ali Jafer Oct 29 '13 at 13:23
  • im using firfox for my testing – resolver101 Oct 29 '13 at 13:25
1

I found the correct URL https://remote.companyname.co.uk:987/default.aspx. This works on all platforms. Thanks for all your help :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.