4

I created a column named "Issue Category" in a issue tracker list. And then, I created a new metadata property with the same name . After that I done two full crawls, but I could't see search results for "IssueCategory:EE" .

metadata property: enter image description here

crawl property: enter image description here

search result:

enter image description here

newest:

When I saw the crawl log , I find a record that 'The SharePoint item being crawled returned an error when attempting to download the item.' on the site. But is not from my list url. The error page is searchadministration.aspx .

  • 1
    Do you have any scopes that could be interfering? – James Love Oct 29 '13 at 8:35
  • @JamesLove All setting is default. I don't have to create any scopes. Need to create a new scope? – seven yang Oct 29 '13 at 9:07
  • 1
    Shouldn't need to - default scopes include everything by default. – James Love Oct 29 '13 at 9:08
  • @JamesLove But the custom metadata property didn't work in this way.The original metadata property had a perfect work. – seven yang Oct 29 '13 at 10:14
  • Do you find the item when you use free text? – Matthew McDermott Oct 30 '13 at 2:28
1

In order to make this work, you need to set up a search schema in the site collection.

On the Managed Properties page, in the Managed property field, type the name of the site column that you want to find the managed property name of.

enter image description here

When that is done, do the full crawl again and see if you get results from that property.

Reference: How to display values from custom managed properties in search results - option 1

  • Thanks for your answer. I can find all of my custom metadata properies in this page. And every time I do the full crawl follow any change . Some different from yours that is my sharepoint versions of 2010.I do not know this will not be affected. – seven yang Nov 4 '13 at 9:38
0

Ensure below:

  1. Managed properties are properly mapped to required crawled properties
  2. Do a full crawl
  3. Ensure that the display template (if edited by adding the new managed property) is uploaded and published
  4. Ensure that the "Update" link in the notification bar is clicked in Result types screen (better to check both at spweb and spsite levels)
  5. Clear browser cache

Perform a search now and see if the new MP is coming up. If still they are not showing up, use the Search SearchQueryToolv2.6 to query and find if the Search API is throwing them up. If all seems fine then do below

Final nail in the coffin would be restarting the SP Timer and SP Administration services. (This step made my changes reflect. Though for others, it worked at step 5)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.