8

SharePoint ribbon is disabled when I click on the edit button using Google Chrome browser. This happens only when my publishing page contains a rich text editor.

Anyone have any idea to resolve this problem?

1

I think this is related to an issue in the v4 masterpage. Try this fix and hopefully it makes things work better.

I thought this issue was resolved in a SharePoint service pack, so I would also make sure you are patched up.

  • Thank you for your response, but the problem is not exactly the same with the issue of the V4 masterpage and the scrol bar in chrome. My problem that the ribbon of sharepoint is disabled only in edit page. I created a simple sharePoint publishing site and i changed the default layout to "Body only" and when i edit the page the ribbon beeing disabled. I think that the issue is related to the ritch text editor in the "body only" layout. Thank in advance. – Balha Oct 29 '13 at 8:58
  • I mentioned this fix because when i was doing a lot of custom SharePoint ribbon development a few months ago, i noticed similar behavior. Mostly, the ribbon would be enabled sometimes and other times it would not. Refreshing the page over and over would sometimes fix it, other times it wouldn't. All of these issues went away when i implemented the above fix. It wasn't solely for the scrolling issue. – ps_md Oct 29 '13 at 15:09
  • This problem is alywas exist event after refrech page many times. the ribbon is displayed but all his button is disabled only in edit mode in chrome browser. Anyway thank you for your help :) – Balha Oct 29 '13 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.