I have a Sharepoint List that has an 'Assigned To' column which is a 'Person or Group' - usually when adding someone it send an email however this has now stopped working.

I've marked 'Yes' in the advanced settings for 'Send e-mail when ownership is assigned?'

I've looked and check the Timer Service is running and it most certainly is, I've even tried restarting it.

  • Is it happening for all the users in "Assigned To" or for a particular user.? Commented Oct 28, 2013 at 14:03
  • what about the smtp server in central admin on web application settings, are the settings correct? is your smtp working at all? did password expired or something?
    – Ivan
    Commented Oct 28, 2013 at 14:05
  • It is happening to any user that I put in as 'Assigned To' - also i've checked the SMPT server and it is indeed correct. I also tried this Sharepoint Test Email from here (which worked): rodneyviana.codeplex.com/releases/view/19103 Commented Oct 28, 2013 at 14:06
  • Check whether the users have valid E-mail ID and also configure UPS to get the valid Email ID from AD. Commented Oct 28, 2013 at 15:08

2 Answers 2


i think it just needs resetting,

set Send e-mail when ownership is assigned to no and save changes, now go back and set it back to yes should do the trick

i think its a small bug in sharepoint where even tho you set yes it still saves the old value of no, so setting it back to no and then yes usually works



run this command in stsadm:

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN: stsadm -o updatealerttemplates -filename "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\XML\customalerttemplates.xml" -url

above resets the template

now run this next command: stsadm -o setproperty -pn job-immediate-alerts -pv "every 1 minutes"

now do an iisreset and the restart the Timer Service job within services. by default the alert is set to 5 min.


  • Thanks for the suggestion but this didn't work. Commented Oct 28, 2013 at 13:55
  • just ammended my answer
    – Ali Jafer
    Commented Oct 28, 2013 at 14:34

Perhaps you are adding/modifying the list items by logging in as system account. Try logging in as any other user and modify the list items and see if the alerts are coming up.

  • I've tried this it doesn't make any difference. Commented Oct 28, 2013 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.