I just extended a Web Application and provided it a new URL and host name. After completion (and altering my host file to direct the new url) I can see the new web sites created in IIS on each of the servers but cannot navigate to it.

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

  • Did you add the new Url as a new Alternate Access Mapping in Central Admin?
    – Sean Regan
    Dec 23, 2010 at 16:10
  • Yes it does that automatically when you extend and existing web application.
    – ChiliYago
    Jan 4, 2011 at 21:45
  • Have you created a site collection before you extending the web app,if yes , try create another one and give it a try.
    – Ybbest
    Jan 20, 2011 at 20:37
  • Did you resolve this issue? how?
    – levi
    Feb 19, 2016 at 7:38

4 Answers 4


Can you provide an anonymized example of your URLS? For example: http://portal.mysite.com, http://mysite.com, etc.

My first thought is you didn't create a site collection when you created the web application. Since you are extending an EXISTING web app, this may not be the case.

Second, it may be a DNS issue. I have run into issues with DNS and Alternate Access Mapping. I could always resolve the site from the web server, but not from any other machine, because the AAM URL was not recorded in DNS.

If you provide more details, we can probably narrow down the problem.


If it was straight away after creating it, then SharePoint & IIS often require an iisreset before everything is happy and the pages will work.


I had this issue today too. I haven't yet tried to solve it, but while searching for a solution, landed on your question. You might have already solved this, but there is no accepted answer. So, I thought I'll post my findings. I found this link and it seems like a good explanation of the issue. I did create webapps before too and they worked fine. I went through their differences and couldn't find any apparent issues. After finding this link, it sounds like the name could be the issue. Then I found this link and it could help with the solution.


Check the binidng in IIS and Alternate access mapping... that is necessary

  • 1
    Please can you expand your answer?
    – SPDoctor
    Sep 5, 2012 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.