3

I've got: - custom master page - custom color palette - custom font schema - and made a preview file

--> deployed to farm

In the "composed look" list everything looks right. But when I go to "Change the look" it do not appear.

I've checked the links (masterpage, fonts, color...) and everything looks right.

3

Also you should have preview file for your custom theme. For example:

  • mymaster.html
  • mymaster.master
  • mymaster.preview
  • I just made a copy of my .master file. Do I need to make a copy of preview and html as well and rename it to my custom masterpage? – Batman Mar 29 '17 at 17:47
  • @Batman - If you use publishing feature then you work with mymaster.html - sharepoint will update mymaster.master file. If you dont have publishing than you have only mymaster.master. Preview file just copy and rename. ps. if you have publishing feature you can "break" connection and just use .master version (edit mymaster.html properties in /_catalogs/masterpage, and uncheck Associated File ) – Marin Buric Mar 31 '17 at 6:26
2

Double check the location of themeurl, fontschemeurl!!! It must be placed under

/_catalogs/theme/15

<Field Name="ThemeUrl">~sitecolletion/_catalogs/theme/15 .... </field>
<Field Name="FontSchemeUrl">~sitecolletion/_catalogs/theme/15 .... </field>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.