0

I have recently migrated our current tfs and sharepoint production system onto a test enviroment to more recent versions. The new installation is a single server farm with sql, tfs and sharepoint, i also run the changeserverid for tfs as i have been told TFS stores GUIDS in the databases - this was run to allow the test enviroment to run allongside the production enviroment.

Problem! TFS urls working fine, find the project sites etc and everything seems to work fine!

SharePoint web part - when i try and go to the projects i get the following error

"There are no accessible team projects in this team project collection. Contact your team foundation server administrator"

Note i have run the sharepoint fix connections procedure with zero errors but didnt fix my issue.

0

already answered here but ill copy the guide:

https://stackoverflow.com/questions/2282953/tfs-2010-sharepoint-web-part-error

1.Open Team Explorer

2.Right click your [TeamProject]

3.Select Team Project Settings > Group Membership

4.Select [TeamProject]\Readers group and click properties

5.Add your user or team groups

also a more detailed guide:

http://msdn.microsoft.com/en-us/library/ms181475(v=vs.100).aspx

Team project settings and properties vary from team project to team project. The team project properties are set from the Team menu in Visual Studio and define settings for groups and permissions which identify members of the team project and their access rights. For example, one software developer may have access to change document X in a team project but not document Y, while another software developer involved in the same team project may have access to change both documents X and Y. Assigning groups helps to establish the various sub-teams within the team project and to better manage the required tasks. Team project settings also include the virtual hierarchical groupings for artifacts within a team project. The classification structure may include the life cycle iterations that make up a team project and the components or features of a team project. Work items and other artifacts such as test cases, may also be classified against the structures/hierarchies to make for easier tracking and reporting.

http://msdn.microsoft.com/en-us/library/ms181234(v=vs.90).aspx

not saying that you didnt back it up properly! but just incase here is a guid on msdn:

http://msdn.microsoft.com/en-us/library/bb552295.aspx

EDIT

for the error:

This site doesn't have a default Team Project. You can explicitly select a specific Team Project. This web part is not configured properly. Click here to configure web part in tool pane.

cause

At it's core this is a communication problem between SharePoint and the Team Foundation Server, and there may be any number of reasons for it, including network connectivity problems. This may also be caused by missing or incorrect Portal Settings for the Team Project in question, or by missing or incorrect Alternate Access Mappings in SharePoint. Finally, it may be caused by missing permissions for the [TEAM FOUNDATION]\SharePoint Web Application Services group to the team project.

solution

You should first verify proper connectivity between the TFS application tier machine(s) and those hosting SharePoint. Then, using the Team Foundation Server Administration Console, verify that the SharePoint Web Applications entry for the Application Tier and SharePoint Web Application in question are established and working. You can use the "Repair Connection" option to confirm this:

1.Open the Team Foundation Server Administration Console

2.Expand the Application Tier in question (the one hosting the Team Project Collection and Team Project with the problem)

3.Highlight the SharePoint Web Applications node.

4.In the SharePoint Web Applications list, highlight the appropriate connection and then click "Repair Connection"

While you are here, verify the membership in the Service Accounts for SharePoint Web Applications as well.

If the "Repair Connection" is successful, next verify the Portal Settings for the Team Project in question. You access this by connecting to the Team Project using Team Explorer. Then, right-click the Team Project name and select "Team Project Settings..." followed by the "Portal Settings..." option. Ensure the values here are correct.

You may also need to update your Alternate Access Mappings in SharePoint (see the More Information section below for details on this).

Also verify that in the “Extension for SharePoint Products” in TFS Administration Console section, make sure that the “Integration Target” column is pointing to the new or fully qualified domain name that you expect in the Team Web Access URL for the TFS Sharepoint portal.

To modify:

  • Click and highlight the row, select “Modify Access”.

  • Then update the “URL for Team Foundation Server” accordingly.

  • Click OK, and then test to see if the TSWA URL is now updated.

other solution if fails follow on here:

http://support.microsoft.com/kb/2451685

  • Thank you for that worked though now i have another error! "This site doesnt have a default team foundation server instance, you can explicitly select a team foundation server - this web part is not configured properly" – Richard Oct 22 '13 at 12:35
  • just update the answer – Ali Jafer Oct 22 '13 at 12:50
  • Thank you for all your help with this! fixed it this morning also another good troubleshooting step is to actual see if the reporting service is granted in localhost/reports !! all the steps proved useful! thank you :) – Richard Oct 23 '13 at 7:46
  • no probs happy to help – Ali Jafer Oct 23 '13 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.