I have configured SharePoint 2013 MySite following http://technet.microsoft.com/en-US/library/ee624362.aspx and then tried to troubleshoot my problem using other guides and questions but i still cannot find a solution. When i go to access mysite via the top nav bar it takes me to a random wrong url which produces a 404 file not found error however when i manually enter what should be the correct url it takes me to the correct mysite....

Can anybody help me?


  • Can you post example of random URL? Are there any entries in ULS log or windows Event log?
    – luccio
    Oct 22, 2013 at 10:09

4 Answers 4


how about setting up the host, your getting 404 beacuse you dont have access, the mysite is setup and exists, you just need it as a trusted site:


My Site host site collection

The My Site host site collection is a special site collection that displays the newsfeed and profile pages of all users' My Sites. The site collection's site template must be the My Site host site template, available from the Enterprise tab of the Create Site Collection page. The My Site host site template can be used only once per User Profile service application, which is discussed later in this article.

My Sites require that a site collection exist at the web application root (which is displayed as / in the user interface). Without this, you will receive a message that states that there is no site collection at the root when you try to enable self-service site creation for the web application. Because we recommend that you use a dedicated web application to host My Sites, you should use the root path for the My Site host collection unless you have a specific requirement to create the site collection deeper in the uniform resource locator (URL) path.



For what it's worth, here's how I usually set up a new My Sites. Configure whichever way suits you best, of course:

  • My Site host: mysites.mycompany.com/
  • Default AAM: mysites.mycompany.com/
  • Wildcard path: /sites/
  • In self-service site creation, path to create new sites: /sites/[%userid%]

In UPS, configure my sites to:

  • My Site host: mysites.mycompany.com/
  • Personal site location: sites

Trusted My Site hosts:

  • mysites.mycompany.com/
  • mysites.mycompany.com/sites/

(Of course, use http or https where applicable :) )

Do remember to chunk any previously-configured personal sites you might've created earlier. Otherwise, funkiness might happen. :)

Hope that helps!


I believe this article describes your problem. Give it a try: http://blogs.msdn.com/b/jorman/archive/2009/01/19/sharepoint-my-site-link-stops-redirecting-users-to-their-personal-site.aspx

They suggest creating MySite collection again.


You might be experiencing similar issues as the ones I had recently. Take a look at this guide right here. One thing you must be sure of is that you configure your trusted-host locations, new-site creation URLS, root site URLs and My Site Host locations properly, or else you will be getting 404s all over the place.

Is this an upgrade or a new farm?

  • It is a brand new farm, thank i will look into this guide.
    – Shwabster
    Oct 22, 2013 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.