1

I am a site collection administrator. When I go into SharePoint Designer 2010 I can see everything. However, when I edit a Master Page, or Page Layout, I get the following error:

You do not have permission to do this operation. Ask your site administrator to change your permissions and then try again, or log on with a user account that has this permission. To log on with a different user account click OK.

I have made sure that all the files on the site are checked-in/approved, and still no luck.

Anyone have any ideas for things to look at, or try?

Note: This looks to be the same as this issue, just in 2010.

1
  • Where is your master page located? check your master page gallery permissions.
    – ova
    Commented May 2, 2012 at 9:42

1 Answer 1

1

I see 2 different options :

  • Could it be that you disabled the SharePoint Designer in the Site Collection Advanced Settings?
  • Do you have some WebApplication policy that are set on that WebApplication that would give you readonly permission ?
4
  • Could it be that you disabled the SharePoint Designer in the Site Collection Advanced Settings? >> Nothing disabled. Do you have some WebApplication policy that are set on that WebApplication that would give you readonly permission ? > Will check.
    – mcnarya
    Commented Dec 21, 2010 at 19:38
  • Do you have some WebApplication policy that are set on that WebApplication that would give you readonly permission ? > None that we set
    – mcnarya
    Commented Dec 21, 2010 at 20:14
  • You are editing from a client machine, of directly from the server ? Commented Dec 21, 2010 at 21:20
  • Editing from both a client and directly on the server produce the same result.
    – mcnarya
    Commented Dec 27, 2010 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.