1

After a considerable amount of headache with a strange server configuration I inherited from the past SysAdmin, I managed to clean up old installations of SharePoint on our Windows Server 2008 R2 system here in the office.

More headaches and unplanned restarts later, I finally have the prerequisites for SharePoint 2013 installed, and have it set up and configured. I began importing data from our old SharePoint site hosted on our GoDaddy account. A few memory limiting configuration changes later, I get everything functioning at a reasonable speed, looking the way I want it to, etc.

So now I'm copying data into the new SharePoint site, and I've started setting permissions on different items using the "Share" option.

As I go through, I'm finding that I cannot view the "permissions" using the "Shared With" option. It immediately throws the "Unexpected response data from server." message.

I'm also having issues with viewing users and groups as I'm sharing. I keep getting the "Sorry, we're having trouble reaching the server." error.

I've seen many different guides say that it's because the server is low on resources, but I've managed to get 6GB of ram freed on the server, and neither the processor or disk are experiencing high levels of usage at the time.

Hopefully someone has some hidden insight on this, I've looked through several different guides that haven't brought me any information. I suspect that it may have to do with my Alternate Access Mapping settings, as I'm accessing it from both inside and outside of the network with different DNS mappings. I don't get any error when I'm accessing it since making the configuration changes to include all of the methods I'm using to access the server.

The site is served from the local server, at sharepoint.domainname.com where sharepoint is a mapped A record from the DNS Server. The site also hosts remote.domainname.com, but not www.domainname. The site is setup with host headers for servername.local:31415, servername:31415, sharepoint.domainname.com:80, and sharepoint.domainname.com:31415 These are mirrored in the Alternate Access Mappings in the SharePoint configuration.

Is there something I may have missed in configuring these that may cause the issue? I'm going to do some additional testing from the original host header mapping for the site (sharepoint.domainname.com:31415), to see if that resolves some of those issues, I'll report back with my findings, but I thought I'd get the question out there in case there's some insight you could provide.

Thanks in advance!

Edit:

I've done some more troubleshooting. I've connected to the site using multiple different host headers, and still receive the same error. I do have an additional error being presented that might also have something to do with it. When opening up the SharePoint Designer to run a diagnostic on the server, I found that I was unable to open the site. I was presented with the "Server could not complete your request" error with a blank details box. There aren't any errors logged on the server in any of the log files. IIS, Event Viewer, etc. don't show any additional errors at the time the request was made.

  • Simply open a command prompt and do an iisreset may fix it. – Kirin Jan Feb 5 at 20:14
1

This might be your solution: http://support.microsoft.com/kb/2758431

I had this bug, it was a nasty combination of Office 2013 document read only, cannot see with who the site is shared, cannot update task list in quick edit, no visual studio access to the site and no SharePoint designer access to the site.

| improve this answer | |
1

I've seen this quite a bit when the client.svc simply stopped working for a particular site. Usually restarting IIS would fix it, but in some cases you might need to double check that all the required application pools are actually running.

| improve this answer | |
  • Restarting IIS worked for me: SharePoint 2013, SSRS 2014, Server OS 2012, and my application pools had no trouble starting. Upvote for Dylan Nicholson! Thanks! – lowJack Sep 7 '18 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.