Brief Description:

Users will receive a ".xml already exists" or a "site doesn't exist" error message when submitting. This is not actually the case as I have verified that there is no file in that list with that name. I can submit the form on their behalf without any problems.


I have recently started working on my works sharepoint site (2 weeks experience now - newbie) and I have been making a lot of positive changes whilst learning a lot about sharepoint. I have created these forms in infopath which were working PRIOR to me wiping permissions on the entire farm. I restructured all the permissions which seem to be working for 90% of the site now but unfortunately users other than IT cannot submit forms. I have made a library with "Intranet visitors" that have access to adding list items (same custom group prior to my farm permission wipe). But the forms will not submit, and the error message doesn't look like a permission problem. I have manually added a test account to the list permission with full control, logged into a PC as that test account and tried to submit the form; same problem.

Is there some "write" permissions for intranet shares that I need to set? This is really puzzling me and draining my day by researching into it without success.

2 Answers 2


I cannot add comments but I can add an answer. Although this will lead you to your answer.

First, your form users need access to the site that hosts your form library. Generally, Read and Form Contribute is enough.

They also need to have 'Forms Contribute' permission (with or without Delete, depending on your requirements) to your form library.

Then they also need read permission to any list that your form reads to work properly. If any of those lists live in another site, they will also need to have Read permission to those other sites.

I'm not quit sure what you meant by "intranet shares".


Did you check if all the dataconnections used in the infopath form were approved? I have experienced that the error message was very obscure and similar to what you describe. The reason in my case was, that the data connection file was not approved and therefor could only be seen by the siteowners for which the form worked as expected.

regards Lars Kohsel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.