1

I am using SharePoint Designer to work on a DispForm.aspx form for a list which has some related lists tied to it. Up until today, the form would render in the browser as:

list entry details for this record
----
related list a
----
related list b

Just what I wanted.

But now, I am eternally stuck with:

related list a
----
related list b
----
list entry details for this record

Argh! I have tried editing the Web Part positioning. Nope. I have tried in SPD to manually edit the "PartOrder" tag for the web part. Nope. My changes get saved, and rewritten, each time.

Neither Google nor Bing were my friend on this. Fwiw, I am using SP2010 Server.

2

I have had this problem, and here are the steps I've taken to resolve it. I have no idea if all these steps are necessary, and feedback is welcome.

  1. Check out DispForm.aspx
  2. Ignore the Design view and go straight to the code. Cut and paste the web part code to where you want it. This is usually enough. (Don't forget to check it back in!)
  3. Escalating the troubleshooting: If it's still not working, remove the web part code for one or more of them entirely from the page. Paste it into a text editor to ensure you don't lose it. Save the page and see if it's gone. Paste it back in the correct order. Save and verify, then check in if it's working.
  4. Further escalating: delete and rebuild one or more of your web parts.
  5. Nuclear option: Delete everything within the Main WebPartZone and build it fresh. Luckily, rebuilding from scratch isn't that painful, especially relative to how hard troubleshooting can get.
| improve this answer | |
  • I tried the #2 suggestion, and got something I forgot about mentioning earlier... While rearranging the parts manually works, the related list parts now display "Web Part Error: The tag contains duplicate '__designer:CustomXsl' attributes." And indeed, looking at the code shows the error msg to be true. I remove the duplicate tags, and ka-pow, it snaps back to the unwanted 'at bottom' format. Aargh! – Alan M Oct 15 '13 at 15:58
  • If you're cut-pasting everything from <WebPartPages:XsltListViewWebPart ...> to </WebPartPages:XsltListViewWebPart> I don't understand how you can get an extra __designer:CustomXsl showing up since that's an attribute of the XsltListViewWebPart. Is SPD altering your code after you paste it? It might be time to try step 3. – Aron Foster Oct 15 '13 at 16:20
  • Got it ironed out. Finally. Solution was to remove ALL the related-list web parts, and add them back in via the Design view. Fwiw, when I'd try using Code view, the nightmare returned and everything reordered. Once I got the related-list parts in via Design view, I was then able via browser to change the Web Part Properties as needed. What misery. – Alan M Oct 15 '13 at 18:02
  • Oh, and YES, indeed, SPD is injecting in an additional unwanted __designer:CustomXsl. In fact, when this occurs it is a sign that the ordering has been flipped on me. Truly SPD = SharePoint Destroyer. Truly. – Alan M Oct 15 '13 at 18:03
  • I have spent many, many hours fighting similar battles with SPD. You have my sympathy. In its defense, it does a good job of preventing you from inadvertently opening security vulnerabilities, and at least it's (mostly) consistent in how it "helps" you. – Aron Foster Oct 15 '13 at 18:10
0

I know it has been long, but none of the solutions above worked for me (even Aron's nuclear option!)

Aron, you have my +1 and I hope that anyone experiencing the same problem can fix it easily by using your escalation system. I will just leave here a brute force option which worked for me.

Look at your markup. You will see that webparts are placed within a ZoneTemplate tag. And that tag is a child of a WebPartZone tag.

Just create another webpart zone, along with its zone template. Give it another title and ID. SharePoint's webparts may give you lip when it comes to ordering, but webpart zone ordering - which is purely positional on the markup - is final and cannot be resisted.

Good luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.