1

I want to change the URL of my team site collection, to do so i have back-up the site collection from inside the old URL, and i want to restore it to the new URL. so i did the following:-

-i create a new site collection on the root of my web application . http://gvsps01:80

-i back-up my current team site from the old URL.

-when i tried to restore the site collection to the new URL i got the following error:-

Restore-spsite : The operation that you are attempting to perform cannot be
completed successfully.  No content databases in the web application were
available to store your site collection.  The existing content databases may
have reached the maximum number of site collections, or be set to read-only,
or be offline, or may already contain a copy of this site collection.  Create
another content database for the Web application and then try the operation
again.
At line:1 char:1
+ Restore-spsite -identity http://gvsps01:80   -path c:\root\i -force
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...dletRestoreSite:
   SPCmdletRestoreSite) [Restore-SPSite], InvalidOperationException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRestoreS
   ite

so can anyone advice please, as all the articles which is talking about this error, is related to if someone delete a site collection from the same URL and try to restore it, while in my case there was not any previouse site collection on the http://gvsps01:80?

  • 1
    Is your old site collection still resides inside the Web Application in which you are trying to restore.? – Karthik Jaganathan Oct 11 '13 at 11:41
  • 1
    few weeks back I faced the same issue, In Central Administration, for that particular web application, I created a new Content database and I tried to restore, then restore worked perfectly. I dont know whether its the right way to do, but this resolved the problem for me, as it was very urgent issue for me, I did it. – Karthik Jaganathan Oct 11 '13 at 11:45
  • yes the old site collection is still there. regarding creating a new content DB, how i can do so , and how i can link the content database with the new site collection. can you explain please. also this is urgent in my case as i am currently working on production and i am stucked with this issue !! – john Gu Oct 11 '13 at 11:48
  • So its like we are trying to place the same database again in the web application and GUID of it is causing the error, I went to central admin -> Manage content database -> Select your web application -> Add a content database, then I ran my powershell script to restore, then restore worked perfectly by puting the database into newly created content database. – Karthik Jaganathan Oct 11 '13 at 11:53
  • thanks for the reply, so should i first delete the exsisting data base first ? – john Gu Oct 11 '13 at 11:56
1

after all, what i did is; 1)back-up the old site collection, 2)delete the old site collection using CA UI, 3)use the following Remove-SPDeletedSite –Identity ... to remove the site collection permanently 4) run the delete job 5) wait for a while . restore agian and it worked !!!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.