Refiners for multi-valued managed properties do not behave like they do for Site Columns when they are created. Values are being refined to "Value one;Value two;Value three" instead of:

  • Value one - (3)
  • Vaue two - (4)
  • Value three - (5)

I've seen SharePoint 2010 posts that answer the question but not 2013. Any help would be a appreciated!

  • I would love to know where those posts are for 2010 as I know nothing about this
    – user20817
    Nov 15, 2013 at 23:55

3 Answers 3


Actually separators are not used any longer in SharePoint 2013. The multivalue field needs to be populated using a List of items, e.g. List<string>.

I'm using Content Enrichtment to populate my field using Property<List<string>> ; a good example from Microsoft:

How to: Use the Content Enrichment web service callout for SharePoint Server

I found another interesting sample in the Microsoft forums:

Index a multiple value column in BCS external content type "SharePoint 2013"

  • Not true, List<> is not an acceptable value for a property. Only string, int and DateTime are
    – hyankov
    Dec 10, 2014 at 12:20
  • List<string> is accepted. You just need to make the Managed Property accept multiple values. Please make this a marked answer! Also here a Link with a good sample: blendmaster.net/blog/2012/09/…
    – Markus S
    Jul 9, 2015 at 14:52

Create a custom Filter based on the OOB MultiField one. Split the filters into new filters, instead of hex use the actual plain text value.

I have described everything here: https://hyankov.wordpress.com/2014/12/15/sharepoint-2013-refiner-multi-value-contains-instead-of-an-equals/


The simple answer to this question in SharePoint 2013 is to make the Managed Property 'Allow multiple values'. This is done through Search Schema in the settings list.

This allows a single option to match, even when multi-choices are selected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.