I have login to the central administration of SharePoint 2013, and I have tried to create a new web application, after setting the web application values (port, database ip ,etc) and I click on OK button. The web application dialog keep showing ”working on it. This should not take too long”. So open central admin on another web browser, and the web application was there, but when I click on “general setting” I got the following error:-

Sorry, something went wrong Updates are currently disallowed on GET requests. To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb.

So what is causing this error?


Resolution via SharePoint 2010 management shell

Launch shell and and add these lines:

$w = get-spwebapplication http://yourwebapplication

We faced the same issue in our development environment few days back, we were getting it; from the newly created web applications. We were not creating web appplications daily, so we dint know the solution, I noticed the error stack trace and noted "EnsureHttpThrottleSettings" and found that CA is trying to do update using the GET request.

Run to below powershell code to get rid of the above error,

$ca = get-spwebapplication http://Nameofproblemwebapp 


HttpThrottleSettings is used to ensure that they exist in the web application and update() is used to saves them, after executing the above code, we dint get that error.

hope this helps you.


Sounds like something broke creating the web app. Try removing it from Central Admin then re-creating it.

  • i remove it , and recreate it , but still the same issue,, it is now taking 30 minutes... still running !!!
    – john Gu
    Oct 9 '13 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.