0

I have a column that I created for a library, which I made a site column before adding it to the library page. When I created the column I made it a required column to ensure the column had a value in it. I now would like to change this column to no longer be required and am having some trouble. I have changed the column settings from the library settings page (clicking library settings then selecting the appropriate column) and also the settings of the site column (selecting site settings, then site columns and then the appropriate column, but when I create a new document the document will not save without entering a value in the column that I have now made a not required column.

Any suggestions?

  • Are you doing this with PowerShell or throughout the User Interface – Alvmad Oct 8 '13 at 9:06
  • User Interface, I do not know how to use Powershell – user19482 Oct 8 '13 at 9:32
  • Are you receiving a kind of error. I tested your issue and both changing the site column to Non-required and column in the library I am allowed to save the document with no data in the column – Alvmad Oct 8 '13 at 9:42
  • Have you ever change the default list form for item addition? – bagus ilman Oct 8 '13 at 9:47
  • Thanks for your help, I have found the solution!! I had the management of content types selected earlier and unselected currently. I reselected this and changed the settings through selecting document and then the column and changing it to optional. Not sure why this would need to be changed if management of content types is not selected, but there you go. Thanks Kate. – user19482 Oct 8 '13 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.