1

I'm having trouble trying to save a SharePoint 2010 site as template.

SPSolutionExporter: Microsoft.SharePoint.SPException: Feature definition with Id a4fbae30-a689-43d0-8f75-484a940336cf failed validation, file 'SE_Delivery_template_20131004ListInstances\ElementsFields.xml', line 581, character 364: The 'EntityName' attribute is not allowed. at Microsoft.SharePoint.Administration.SPSolutionPackage.SolutionFile.FeatureXmlValidationCallBack(Object sender, ValidationEventArgs evtargs) at System.Xml.Schema.XmlSchemaValidator.SendValidationEvent(String code, String arg) at System.Xml.Schema.XmlSchemaValidator.ValidateAttribute(String lName, String ns, XmlValueGetter attributeValueGetter, String attributeStringValue, XmlSchemaInfo schemaInfo) at System.Xml.XsdValidatingReader.ValidateAttributes() at System.Xml.XsdValidatingReader.ProcessElementEvent() at System.Xml.XsdValidatingReader.Read() at System.Xml.XmlReader.MoveToContent() at System.Xml.XmlReader.IsStartElement() at Microsoft.SharePoint.Utilities.SPUtility.XsdValidateXml(XmlTextReader xmlStreamReader, String friendlyName, String pathXsdFile, String tagExpectedRootNode, ValidationEventHandler xsdValEventHandler) at Microsoft.SharePoint.Administration.SPSolutionPackage.SolutionFile.ValidateFeatureXmlFile(String rootTagElement) at Microsoft.SharePoint.Administration.SPSolutionPackage.AddFeatureElementsCore(XmlNodeList nodeList, String strFeatureDirRelativeToCabFile, Guid featureId, Dictionary`2 filesAdded) at Microsoft.SharePoint.Administration.SPSolutionPackage.AddFeatureElements(XmlNode root, String strFeatureDirRelativeToCabFile, String strFeatureXmlFilename, Guid featureId) at Microsoft.SharePoint.Administration.SPSolutionPackage.WspSolutionFeature.ProcessFeatureXml() at Microsoft.SharePoint.Administration.SPSolutionPackage.InitSolutionFeatures(XmlNode root) at Microsoft.SharePoint.Administration.SPSolutionPackage.ProcessSolutionManifest() at Microsoft.SharePoint.Administration.SPSolutionPackage.Load() at Microsoft.SharePoint.Administration.SPSolutionLanguagePack.CreateSolutionPackage(SPRequest request, String name, String signature, Byte[] fileBytes) at Microsoft.SharePoint.SPUserSolutionCollection.<>c_DisplayClass1.b_0() at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode) at Microsoft.SharePoint.SPUserSolutionCollection.AddOrUpgrade(SPListItem item, SPUserSolution existingSolution) at Microsoft.SharePoint.SPUserSolutionCollection.Add(Int32 solutionGalleryItemId) at Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent, String workflowTemplateName, String destinationListUrl)

When I look into the Solution Galleries, I can see the wsp file there. When I try to activate it, I get the following error:

Feature definition with Id ab614de8-41e0-4ad2-93da-49daf51285d3 failed validation, file 'SE_Delivery_template_20131004ListInstances\ElementsFields.xml', line 581, character 364: The 'EntityName' attribute is not allowed.

So I downloaded this wsp file to take a look inside it and

<Field Type="BusinessData" DisplayName="ES Projects" Required="FALSE" EnforceUniqueValues="FALSE" Group="IMS" ID="{27a81718-4feb-4369-acde-0af56ae760cb}" SourceID="{952e3e98-3e76-4b93-8f3f-ad4b6725d71a}" StaticName="ES_x0020_Projects" Name="ES_x0020_Projects" SystemInstance="dbName" EntityNamespace="http://spSite/assets" EntityName="ESProjectList" BdcField="ProjectNumber_And_Name" Profile="" HasActions="True" SecondaryFieldBdcNames="0" RelatedField="ESProjectList_ID" SecondaryFieldWssNames="0" RelatedFieldBDCField="" RelatedFieldWssStaticName="ESProjectList_ID" SecondaryFieldsWssStaticNames="0" AddFieldOption="AddFieldInternalNameHint" Overwrite="TRUE" />

This is an External Content Type that I had used. Thing is, that it's just part of the site since it is inheriting it from the parent site and we may want to use it in the future. This is a site column actually.

So now I'm stuck with this, since I cannot create a modified version of the Site Template because of this error. Could you please give me some tips & tricks to solve this?

Kind regards, Imran

0

Can you confirm the custom feature with ID of 038ab85a-fb82-457d-ba1d-062741085d82? Are you sure there are no custom global solutions/template changes which get rolled out to your team site.

| improve this answer | |
  • This ID is not there in the text I mentioned Falak. Could you check that again please. – A.K Oct 4 '13 at 13:38
  • It turns out that a EntityNameattribute is an external data or BCS column that is causing the problem. You need to investigate the contents of the WSP file deploying it. – Falak Mahmood Oct 4 '13 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.