0

I was messing with SP's library forms (I think) a while back. Gave up eventually, because that wasn't really what I wanted. I did manage to break something, somewhere, though. Namely, the links to the default Shared Documents Library point to my /SitePages/Custom.aspx page.

For example, Site Actions > All site content > Document Libraries > Shared Documents links to Custom.aspx.

The library works fine and is available on its original URL, /Shared Documents, but the problem is that SP still links it to the custom page, which is not what I intend, and I can't remember what I did to change that.

1

Perhaps you have changed the Default View of the Library. Go to Library Settings. Scroll Down and you will see a section named Views. Click on All Documents view. Check the option "Make this the Default View".

| improve this answer | |
  • Yes, this was it! The library had no default view. I suppose I did set my custom page to be the default view, but I had deleted it eventually, so none of the existing views in the Library Settings > Views section were ticked. Thank you! – Andrei Mustață Oct 1 '13 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.