0

This is sp2010. Got a site collection I'm building to let users across our org submit articles for displaying on the site. I got a list and the list contains a multiple-line text column which allows rich text content. No problems there, works as expected.

But, let's say you are adding a new item to that list. And you are not a SharePoint veteran, just John Doe Office Worker. You are editing text in the rich text editor and want to add a photo. In the ribbon, click Insert > Picture > From Computer. A modal dialog pops up, "Select Picture". There is the Name field with the "Browse" button. The next one, though, ugh. There is a "Upload to:" lookup, to select the destination document library to store the image in. That lookup field defaults to "Customized Reports". Making it worse is this paragraph of red complaint text whining about different permissions, but that's a different story.

So, that "Upload to:" lookup, is there a known way to force it to default to "Site Collection Images" instead of "Customized Reports"?

1

Is interesting that it points by default to that library. Is it the only in the Site? Has anyone by mistake marked that as "Use as Site assets" (via Settings)?

By default the Asset picker should look into the Web/Site Images library. Also, by default it remembers last successful selection, unless settings have been tampered with for the control. Have a look here for options to validate (DefaultOpenLocationUrl, DefaultToLastUsedLocation) http://msdn.microsoft.com/en-us/library/ms543215(v=office.14).aspx

If you are in a Publishing site, therefore using Page Layouts, you can directly check/update these settings in the appropriate control. At that stage I would suggest you rather use the Publishing Image field in the content type which in Edit mode would allow the "Browse" experience - totally different than simply Hyperlink/Picture field.

  • You know, I bet that oddball "Customized Reports" folder got in there by way of activating the "Reporting" feature. I ponder this possiblity cuz' I'm looking at that "Customized Reports" library in SPD. It shows in the Settings section, Document Template URL: /AnalyticsReports/Forms/template.xls – Alan M Sep 30 '13 at 16:15
  • Your first paragraph led me to the answer. Looking at the document library where I wanted images to go to, in Advanced Settings, there is a "Site Assets Library - Specify whether this library should be presented as the default location..." and setting that to Yes did the job. The default for uploaded images is now my desired "Photos" library. – Alan M Sep 30 '13 at 16:24
  • Actually that is more related to the Usage analytics features of a Publishing site (technet.microsoft.com/en-us/library/gg266383.aspx) – Marius Constantinescu - MVP Sep 30 '13 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.