1

I am doing a basic filename search within a document library. When I enter part of the title, not all of the results are being returned.

(i.e. I enter filename:Aide The results return a document called Cafeteria Aide but it doesn't return the document Deli Aide.) I have verified that the document exists and there are no underscores in the file name. I have done an Index reset followed by a full crawl but it still doesn't show up. Can anyone help me with what I am missing or What I can do to receive all documents?

Thanks.

1
  • Have you looked at the crawl logs and confirmed that the document was indexed? What is the file extension? Is it a duplicate? Sep 28, 2013 at 10:18

2 Answers 2

1

A few things to check:

  • Is the doc in the index (check the crawl logs from CA)?
  • Is the doc published (in case minor versions are enabled on the doc lib)?
  • Does the user have access to that doc?
  • Is the "missing" doc less than 50MB?
  • Is it a "standard" file format (docx, doc...)?
3
  • Less than 50MB? Do you mean less than 50KB? (But even then, SP should still be indexing docs that are smaller than this - Word documents can be significantly smaller, for instance.)
    – Hutch
    Feb 3, 2016 at 16:25
  • 1
    I confirm: 50MB. By default, SharePoint does not index files >50MB.
    – Evariste
    Feb 3, 2016 at 16:41
  • Thansk for the confirmation - For some reason I had it backwards (was thinking there was a min size instead of a max size). Obviously I wasn't thinking too clearly :)
    – Hutch
    Feb 3, 2016 at 17:21
0

Take a look at your crawl rules in central administration, maybe your library which contains the document isn't included. Also you can check by searching for your document by url in crawl log as Matthew McDermott suggested. SharePoint search also doesn't show you the document if the user you're searching with doesn't have permissions to view the library of the item. Also there is a setting on a library itself either to show it's contents in search results or not. Good luck! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.