I cannot see it anywhere: neither in Edit -> Insert -> Web Part, nor Edit -> Insert -> App Part. Do I have to enable a certain Feature to be able to use Newsfeed?

  • Here it is: Insert > WebPart > Social Collboration > Site Feed. – rjose Aug 1 '17 at 7:02
up vote 26 down vote accepted

Yes. You need to activate Site Feed feature in Site Settings --> Manage site features. Then, when adding web part, under Site Collaboration group you will have the Site Feed WebPart

UPDATED

Yo must activate this feature in _layouts/15/ManageFeatures.aspx enter image description here

  • I still dont see the option to add news feed. I have already activated the site feature. – user21531 Dec 19 '13 at 18:03
  • The feature is called "Site Feed" – Alvmad Dec 20 '13 at 8:46
  • I don't see it either. I'm on a Team site and the Site feed webpart is on the default home page. But I cannot see it under Social Collaboration or any other category – Colbs May 7 '14 at 15:56
  • I updated the post with a picture – Alvmad May 7 '14 at 22:06
  • 3
    See the answer from Anders Austad- the Site Feed feature needs to be activated in the site collection root web as well, for some reason. Doing this got the Site Feed web part to show up for me in my sub site. – Matt Connolly May 15 '14 at 18:30

As stated by others: The "Site feed" feature needs to be activated on the site where you are trying to add the Newsfeed webpart.

But there is one very important gotcha: The "Site feed" feature also needs to be activated on the site collection root site if you are working on a sub-site. I found this out by accident a while ago, went back and checked it now on SP 2013 SP1, and the issue has not been fixed. You still have to activate the feature on the root site.

  • 2
    Current SP-Online as of today -> still need to activate "SiteFeed" on Site & rootSite ! – Nils Jan 18 '16 at 13:37

Just a clarification - This is NOT an issue but just the way SP is designed.

Essentially allowing for more granular control across your site.

Features need to be enabled top down (Application all the way to the subsite level) Only then the feature is available. Still needs to be turned on - does NOT get turned on by default on all sites (understandably as you would not want features turning on by default across the few hundred sites/subsites you may have).

Just download the sitefeed webpart: site settings\ under web designer galleries go to web parts. if you do not see this go to top level site collection and go to web parts\ look to see if you can find site feed web part, if you do download it to desktop, go to site you want site feed webpart, edit the page, click on the zone where you want to add a webpart, insert a webpart, under categories upload a web part and browse and upload, you can add now. if you do not see the site feed web part in the gallery click files, new document, new, now you can check the box for site feed web part to add site feed webpart to the gallery and you can do rest by following above instructions.

Go to Insert, under categories scroll to Social Collaboration, under Parts click Newsfeed and add.

  • 2
    It clearly states in the question that the webpart is not visible here – Robert Lindgren Dec 17 '15 at 15:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.