I have a content query webpart, it's rending item url as http://site/Lists/item/2_.000, I have to edit the webpart and remove the value of the Url Path, from the link field, then it will work fine, how do I solve this?

  • did you try with the <xsl:text disable-output-escaping="yes"> ? Sep 26, 2013 at 5:04
  • for the title itself? why would I want to use that? Sep 26, 2013 at 9:38

1 Answer 1


Edit the web part in the browser, open up the Presentation section and scroll down towards the bottom of that section. You will find Fields to Display. Here you can choose which fields populate which parts of the XSL when it is presented - or remove elements if needed.

  • Hi Dave, thanks for your reply. but in my requirement, I need to insert the webpart programmatically in a module to many pages, I can't repeat this procedure everywhere, is there some settings that can be changed? something with xsl maybe? Sep 26, 2013 at 9:37
  • Yes, you can customise the XSLT but again you need to be able to apply it to multiple pages. The way I generally work with custom CQWP is to link them to copies the standard XSL files, set them up the way I want them through the settings, then export and import to the web part gallery. You can then use the web part in multiple pages as with any other web part. A couple of posts on my blog cover this topic paylord.wordpress.com. There may well be other ways to do this through code but I am no developer. Sep 26, 2013 at 20:37
  • Hi Dave, thanks for your email, yes but my problem is with this rendering thing, I guess we went away of the original target here, what property exactly in the xsl should I alter to modify the rendering of the url to be correct? Sep 27, 2013 at 2:55
  • Is the link itself working or is it just the label on the link you want to change? The easiest is probably for you to edit your question and include an extract of the XSL you are using. Sep 27, 2013 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.