3

I can create data sources that connect to SQL Analysis Servier 2012 instances, but not to the PowerPivot instance.

I followed the instructions here: http://technet.microsoft.com/en-us/library/ff191197.aspx

I used a connection string like this:

PROVIDER=MSOLAP;DATA SOURCE=http://contoso/Documents/PowerPivot_Sample.xlsx

I get the following error after trying to select a cube from the drop down: An error occurred connecting to this data source

The Event viewer gives the following error:

The Unattended Service Account "mydomain\myuser" does not have access to the server specified by the data source connection string.

Data source location: http://spdev2013-3/sites/testbicenter/Data Connections/19_.000
Data source name: New Data Source 10

Exception details:
Microsoft.AnalysisServices.AdomdClient.AdomdConnectionException: A connection cannot be made. Ensure that the server is running. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.AnalysisServices.SharePoint.Integration, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
   at Microsoft.AnalysisServices.AdomdClient.XmlaClient.WCFConnect(String dataSource, String dataSourceVersion, String& timeLastModified, String& databaseId, String& databaseName, String& loginName, String& serverEndpointAddress)
   at Microsoft.AnalysisServices.AdomdClient.XmlaClient.OpenWcfConnection(ConnectionInfo connectionInfo)
   at Microsoft.AnalysisServices.AdomdClient.XmlaClient.Connect(ConnectionInfo connectionInfo, Boolean beginSession)
   --- End of inner exception stack trace ---
   at Microsoft.AnalysisServices.AdomdClient.XmlaClient.Connect(ConnectionInfo connectionInfo, Boolean beginSession)
   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.XmlaClientProvider.Connect(Boolean toIXMLA)
   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.ConnectToXMLA(Boolean createSession, Boolean isHTTP)
   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.Open()
   at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.AdomdConnectionPool`1.c__DisplayClass4.b__2()
   at Microsoft.SharePoint.SPSecurity.c__DisplayClass5.b__3()
   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)
   at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.AdomdConnectionPool`1.GetConnection(String connectionString, ConnectionContext connectionCtx, String effectiveUserName, CultureInfo culture, NewConnectionHandler newConnectionHandler, TestConnectionHandler testConnectionHandler, String targetAppId)

Following the instructions here I installed:

  1. Microsoft® SQL Server® 2012 ADOMD.NET and Microsoft® Analysis Services OLE DB Provider for Microsoft® SQL Server® 2012 from the Microsoft® SQL Server® 2012 Feature Pack on the WFE and the server running the PPS Service
  2. Microsoft® SQL Server® 2008 R2 ADOMD.NET and Microsoft® Analysis Services OLE DB Provider for Microsoft® SQL Server® 2008 R2 from the Microsoft® SQL Server® 2008 R2 Feature Pack on the WFE and the server running the PPS Service

More info on why these steps are required is available here. Also because of a suggestion on this page I installed SQL Server 2008 R2 SP1 to update the components

I also tried to redeploy the PowerPivot farm solution.

I also verified the PowerPivot installation according to these instructions and I can view Excel spreadsheets that use PowerPivot in Excel Services, so I think that means it is working correctly.

1

On the server hosting the SSAS instance install the desktop experience. When accessing workbooks as a data source from SharePoint, it will connect via WebDav. WebDav is not available on the server by default and is included when you install the desktop experience feature.

Add-WindowsFeature Desktop-Experience
  • Thanks I tried this but I'm still getting the same exception. – Rn222 Sep 26 '13 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.