I have a Workflow (created in SPD 2013) that sends Emails, either directly or through a Approvaltask. The problem is that none of these Emails reach their destination. They don't even reach the Mailserver. The SendMail Command works fine in code, powershell and also in 2010 Workflows (= I actually receive the mail). The Mailserver is in the same domain.

After a lot of research I found out, that the Workflow Engine in 2013 sends Emails anonymously but I already checked and the Emailserver should allow them. Then I thought it might have something to do with the problem that some users do not have a Email assigned as seen in the People Picker. Configuring the Profile Syncronization did set Mails on every user from the Active Directory but the problem was the same.

The Workflow UI of the associated ListItem shows me a 400 Bad Request as soon as the Workflow reaches a Send Mail Command. The only "useful" information from the corresponding SP Logs show Couldn't find a user using property 'WorkEmail' of value 'loginname@domain'. The Email displayed shows the loginname of the user that started the Workflow but it isn't even correct as the users mailaddress is quite different.

What is the problem here? After working a whole week on it, I don't really know what I still could do to resolve this issue.

2 Answers 2


Well I found the solution (by pure luck more or less)... I had to enter the SMTP Server Address in the IIS Manager under SharePoint - 80 Web Application -> "SMTP E-Mail". I don't know why it does not work with the Email settings from the SP Central Administration. More over I do not know why I had to do this in IIS as I checked a different SP Server where Workflow Emails worked just fine and there was no SMTP Server set in IIS.

This leaves me with more questions as it answered but at least it solved my problem.

  • Can you explain what you did to fix the issue?
    – user33299
    Sep 10, 2014 at 21:41
  • 1
    I think I wrote what I did in the answer.
    – Kirschi
    Sep 11, 2014 at 10:56

This is how I solved it: link.
I had to create new workflow using SharePoint 2010 Workflow platform type and call that same workflow when I need it in workflow created using SharePoint 2013 Workflow platform type.
I hope this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.