My initial web application allows me to see and change the master page under site actions\site settings\Look and Feel\master page. I created a second web application and would like to use a different master page, but when I go to site actions\sites settings\Look and Feel the only options I have are:

  • Title, description, and icon
  • Tree view
  • Site theme
  • Navigation

Shouldn't I be able to change\edit the master page for a separate web application?

In Central Administration they are listed as separate web applications with different ports.

I checked my registry and I have the following installed:

  • SharePoint Foundation 2010
  • SharePoint Server 2010 Standard
  • Office Web Companions 2010

Any help would be greatly appreciated!!

4 Answers 4


What type of site are the root of the web applications built on? If you used a team site, you'll probably have to go into Site Actions, Set Settings, Site Collection features and turn on the Office publishing infrastructure feature to enable master page changes.


Activating "SharePoint Server Publishing Infrastructure" feature will enable option to change master page.

Alternatively got to this page to change master page : /_Layouts/ChangeSiteMasterPage.aspx


The page you're expecting is part of the Publishing Infrastructure; you'll need to turn that on.

Alternatively, you can set the master page through SharePoint Designer. To be honest, I'd recommend that; the publishing infrastructure gives you a lot of other things that you might not need.

Other options - a custom feature (though be careful of Meeting Workspaces - in 2007, at least, they have differently structured master pages to the rest of SharePoint). This cab be stapled to your site templates to apply your master page to sites as they're created.


Please see the accepted answer to this question: Master Page option doesn't exist

Reposting here for reference:

follow this steps

  • Goto Site collection feature

  • Activate "SharePoint Server Publishing Infrastructure"

  • Goto Manage site feature

  • Activate "SharePoint Server Publishing"

The link you are missing is only available when publishing is enabled

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – Hugh Wood
    Dec 7, 2012 at 8:33
  • @HughWood - since the user don't exist anymore, I have taken the liberty to fix this post. It feels a dupe of the other answer, but at last now it shouldn't sit on the low post review list anymore.
    – SPArcheon
    Dec 13, 2012 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.