10

An out-of-the-box SP2010 Approval Workflow has been created to a list. The workflow works fine and workflows have successfully been created by end users (non-admins). However, now we noticed that SharePoint had not automatically created the workflow column to the list. But we would need to see the workflow progress status in list views.

Have I just missed something, or would it be possible to

  • Create the column manually or via code

  • Create a new workflow and move all the existing workflows to point to the new workflow

  • or something else?

This is a SP2010 June 2011 CU.

  • Same problem with me. The column is not available in the settings of the default view. Has anybody got any answer for this? – user1853141 Jan 15 '15 at 14:11
1

I think your workflow is not getting triggered because when workflow start the column is automatically created,

the reason may be you are performing the list operation by system account try running workflow from another account.

If you are logged in with system account then please have a look to this Deploying Workflows as 'System Account'? Just Say 'NO!'

Thanks

| improve this answer | |
  • i tried with a normal user account and but still the workflow column status - in progress / error occured is not appearing. can you pls help – userAZLogicApps Dec 16 '16 at 11:57
0

I suppose in your case the column is added to default view but you're still using another (custom) view.

Try to change view and check it once more.

I have reproduced it now and all works as i've predicted :)

Also keep in mind that there is a small delay after workflow is started and a column with its name is added to default view.

When you attach workflow to list (custom using SharePoint Designer or default out of box workflow from list settings), the column with workflow name is automatically addedd to default view.

However if that wasn't happened, edit the view you're using in your list and add a column with your worlfkow name to it.

| improve this answer | |
  • The column is not available in the settings of the default view, and it just doesn't seem to get there. I cannot see the column even from ViewFields via server-side .NET code. Other workflow columns appear correctly though. – thomius Nov 3 '13 at 20:36
  • I solved this simly by creating a new workflow to replace this old one (but the problem is that some workflows were started and I would not like to ask those guys to re-create their workflows... but that's another question). – thomius Nov 3 '13 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.