6

Our organization has Office 2013 applications, and SharePoint 2013 on-premises (which we do use) and Office 365 - SharePoint Online (which we DO NOT use).

Problem is that SharePoint Online is also integrated by default in client Office application (for example. Word or Excel).

I want to remove SharePoint Online from save locations on all computers, and specify only on-premise SharePoint. I believe this can be done using Group policy and ADMX for Office365 but did not find solution (which GPO items should be modified).

3

Unfortunately this is a known issue, and not possible to overcome in todays version:

There are some group policies that control the Backstage area, but they are mostly all or nothing, removing all SharePoint referencing not just the Office 365 ones.

The workaround below should remove the O365 SharePoint on line content from the Office Save As screen and the "SharePoint" link in the contact card.

Workaround: None

Current Status: This is a known issue, it could be addressed in a future version of Microsoft Office.

Posted by Warren_R_Msft in the blog Office 2013, Remove unwanted SharePoint Online / SkyDrive "Save As" backstage items November 26, 2013.

In Word there are options settings for Save available, but it's an all or nothing option on Show additional places for saving, even if sign-in may be required.

enter image description here

Workaround

However, there is kind of a workaround posted by Johnny Zhang MSFT Support on the topic:

Based on my test, we can disable SharePoint site save location as below steps:

  1. From Registry Editor, browse to: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Internet

  2. Create a new DWORD value of UseOnlineContent, Set the value of UseOnlineContent to 1.

  3. Re-open Office application.

Reference: How do I globally disable SharePoint?

It's not a full solution to your problem, but it may give you hints in the right direction.

0

Check out this key:

HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\ServicesManagerCache\Identities\USERNAME@DOMAIN_AD

Remove keys below this root key (user@domain_AD)

0

You can also navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\ServicesManagerCache\Identities\ and view all your Sharepoint/Onedrive locations. I was able to remove them from my Office Save As page by setting the values for ConnectionState and EnabledCapabilities to 0.

NOTE: I've only done this for Sharepoint sites I'm (probably) not ever going to use on this computer anymore, as I'm not certain in which way it could affect your connections/permissions for these sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.