2

I have sharePoint 2010 installed in a dev environment. I am a developer who is reasonably new to SP.

All of a sudden central admin no longer works up until yesterday I was getting there using:

http://dev-sharepoint.dev.local:9999/

When I browse here now I am faced with this:

HTTP/1.1 200 OK Server: Microsoft-IIS/7.5 Date: Wed, 18 Sep 2013 04:03:29 GMT Connection: close

There is nothing in the ULS logs at all. I have spent the last few hours researching however without a clear ULS log entry or a clear browser error I am a bit stuck. here is what I have done:

  1. run the product configuration wizard. note - I did not disconnect from the server farm and I said no this machine will continue to host the web site. It goes through 9 of 9 steps with success and then open a browser at this URL:

    ..._admin/adminconfigintro.aspx?scenarioid=adminconfig& welcomestringid=farmconfigurationwizard_welcome

    but shows this:

Object reference not set to an instance of an object. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: b473c2e3-8b67-4a84-a2d0-ac374b2bbd69 Date and Time: 9/18/2013 2:40:45 PM

when I go into ULS viewer and look at the correlationtree it show this:

System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.SharePoint.WebControls.SPRibbon..ctor() at ASP._admin_admin_master._BuildControl_control30() at ASP._admin_admin_master._BuildControl_control21() at ASP._admin_admin_master._BuildControl_control2() at ASP._admin_admin_master.__BuildControlTree(_admin_admin_master __ctrl) at System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) at System.Web.UI.Page.get_Master()
at System.Web.UI.Page.ApplyMasterPage() at System.Web.UI.Page.PerformPreInit() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

  1. Next I read about provisioning so I ran this:

    psconfig.exe -cmd adminvs -unprovision
    

    and then this:

    psconfig.exe -cmd adminvs provision -port 8888 -windowsauthprovider onlyusentlm
    

    All three steps for both commands ran with success

But I still have no central admin. I ran the product configuration wizard again after the re-provisioning however I get the same result. I have no idea what to do, Help...

The only major thing I did yesterday was to delete two web applications. They were both failed attempts at configuring mySite. I am unsure what I did wrong. I followed these steps [http://sharepointgeorge.com/2010/configuring-my-site-sharepoint-2010/][1] which look very through however after completion I was getting a website can not be displayed when I tried to browse to the profile and the mySite.

I have also recycled both the central admin and the web services root app pools

Editing - adding solution - Apparently this error:

HTTP/1.1 200 OK Server: Microsoft-IIS/7.5 Date: Wed, 18 Sep 2013

means there the web application can not find the site collection. Commonly found if you try to browse to a web application before a site collection is created.

So After hours and hours of research the very last thing I tried was to detach and re-attach the content database. The problem was this did not work:

Dismount-SPContentDatabase "SharePoint_AdminContent_be612b9b-749d-4e20-b5a7-f14aa0c5fd90"

It is thought that its becasue the content database is attached to an SPAdministrationWebApplication web application rather than a normal SPWebApplication. so this did work:

get-spcontentdatabase -webapplication http://siteaddress | dismount-SPcontentdatabase

Then to re-attach:

Mount-SPContentdatabase -name SharePoint_AdminContent_be612b9b-749d-4e20-b5a7-f14aa0c5fd90 -DatabaseServer DEV-SQL01-VM   -Webapplication http://siteaddress 

After this every thigs is back to normal. I still do not know how the occurred

1

I faced that problem earlier.

In my case first i tried to stop and restart User profile Service and User Profile Sync service, then (restart didn't helped) deleted User Profile Service and re-created it.

  • Thank you for you time and advice however I had actually removed the user profile service. I did this because the mySite web application was what I was referring to in the 'The only major thing I did' ....this was the web application that was removed. All this said I ahve a solution. See the edit in the original post – Mat41 Sep 19 '13 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.