2

I have done the following settings:

  1. I set the "Browser File Handling" for the web application to "Strict".
  2. I set the "Opening Documents in the Browser" for the document library to "Open in the client application".

But currently, if the user clicks on a document link inside the document library he will get the following error :

The web page can not be displayed.

And the generated URL will be:

ms-powerpoint:ofv|u|http:// gvstg01:40708/sites/Intranet/Shared%20Documents/TM%20Group%20SD%20PO%20Project%20Process%20v2%2029Nov12.pptx

Although I have specified to open the office document using the client office applications, rather than opening these documents on the client browser.

Any advice on how to force the document library to open the file using the client application? I need the same behavior as when the user select a document and clicking on "Download a copy" button.

Edit

i have also noted the following two points :-

  1. when using Safari 5.1.7 , the browser will automatically display a dialog asking if the user wants to Open or to Save the document . which is what i am searching for.

  2. the problem in IE & Firefox it that they will add extra characters to the generated URL (for example in case of a PowerPoint doc it will add "ms-powerpoint:ofv|u|"), after clicking on an office document, so the generated URL when clicking on a PowerPoint document will be :-

    ms-powerpoint:ofv|u|..://gvstg01:40708/sites/Intranet/Shared%20Documents/TDM%20Group%20SD%20PO%20Project%20Process%20v2%2029Nov12.pptx

and if i manually remove ms-powerpoint:ofv|u|from the URL and reload the page then IE will show a dialog asking if i want to open or to save the document, and this what i am searching for.

so the main problem is that IE is adding extra characters to the URL when clicking on an offie docuemnt?? any idea what is causing this ?

  • thanks for the edit, but do you face this problem before ! it is strange why SharePoint did not manage to use the client office application to open the office documents . as mentioned in the settings ? – john Gu Sep 18 '13 at 10:33
  • hello did you get a fix for this as I am experiencing the same issue. – user21319 Dec 10 '13 at 14:27
1

I have seen this issue when the client has both Office 2010 Suite and an Office 2013 application (e.g., I had SharePoint Designer 2013, or in the case of the post below Project 2013). Try uninstalling the SharePoint Foundation Support feature from the 2013 install and then running the Office 2010 repair tool.

http://blogs.technet.com/b/raymond_ris/archive/2013/04/04/cannot-open-or-create-word-documents-in-sharepoint-2013-with-office-2010-and-project-2013.aspx

Sharepoint 2013-stored/created Office documents not opening in 2010 client is a similar question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.