1

My site has been configured to use forms based authentication. A user can login successfully if the default login page is used.

I have created a custom login page (Application Page) which inherits from IdentityModelSignInPageBase. I have deployed my solution to the site.

I get a HTTP 403 Forbidden when going to the site. How do I configure the right permissions?

1

403 Forbidden normally means some kind of fault that's not permissions based (that'd be 401 Unauthorized).

What I've done for this in the past is have a look at the default login page and see what it inherits, and just make sure your custom one inherits the same class.

0

The first thing to check in this (and many other cases) is the Log files.

  • It can be any error, e.g. your Login page is failing and trying to display an error page.
  • Anonymous users not having access to the master page.
0

I would suggest to take the reference of the below site. It worked well for me without issues.

http://tomaszrabinski.pl/wordpress/2011/06/23/sharepoint-2010-custom-login-page/

  • Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer – Benny Skogberg Mar 25 '14 at 18:41
0

I've had this as well on my WebApp. A restart of the User Synchronization Service resolved this issue.

0

This might be an answer too late, however for future users as myself who might be looking for the same answer. If you have a custom login page that is using the Default MasterPage, then you might run into this issue.

Option 1 is to give anonymous users access to the site (Visit Central Admin, click "Authentication Providers" on the "Application Management > Manage web applications" page; select the zone and select Anonymous Access checkbox. Also give the Anonymous Users permissions for Lists and Libraries) -> This might not be what you want though.

Option 2 is to change the masterpage that is loaded for your custom page.

You can do this: Replace

DynamicMasterPageFile=”~masterurl/default.master” 

with

MasterPageFile=”~/_layouts/customlogin/simple.master”

To save you the hustle, you could adopt the page from https://github.com/dipongkor/FBA-Custom-Login-Page

It's for SharePoint 2013, but we've been able to use the same on SharePoint 2016 by creating a custom page and porting the SharePoint elements.

(Notice how the masterpage used on that is the error.master :) )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.