0

I have enabled search and in People search when I try to search people belonging to a particular department or unit, I couldn't get the search results because department is a custom property.

I have also made full crawl after adding the property. How can I make this work?

6
  • How have you configured the Managed property? Searchable? Retreivable etc? Does it work if you do a "ManagedpropertyName":"IT" search for example? Commented Sep 17, 2013 at 14:53
  • ya I have configured everything..but still when I search for a particular department Iam unable to get people in that department
    – nit
    Commented Sep 17, 2013 at 15:00
  • My question was not "If, but "how" you have configured the property Commented Sep 17, 2013 at 15:01
  • If Iam not wrong are u aasking me whether i have enabled the check boxes in managed property?if yes ya i have enabled it.
    – nit
    Commented Sep 18, 2013 at 11:08
  • Are you searching on the People Vertical? People results are excluded from the default Search Vertical. Commented Sep 18, 2013 at 13:05

1 Answer 1

0

back from SharePoint 2010 I remember that adding a Managed Property is a change in the Search Schema. As such it needed a Full Crawl to become effective. My guess is that this behavior hasn't changed in SharePoint 2013 and that your index doesn't reflect your recent changes yet.

Does this help you?

Cheers René

2
  • Do you want me to make index reset?
    – nit
    Commented Sep 19, 2013 at 6:40
  • Can u tell me default webparts available in sharepoint2013 for search
    – nit
    Commented Sep 20, 2013 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.