0

Morning all,

Here's my scenario: -

I've made a new web application within SharePoint 2010 via the GUI. This went ahead with no problems. From here, I've created the root site, which also reported no problems. Having checked the ULS, both of these can be confirmed as working fine. Upon browsing to the root site url, I get the infamous "Internet Explorer cannot display the webpage."

My fixes thus far have been

  1. Rebooting IIS
  2. Flushing the DNS
  3. Adding a binding in IIS

It doesn't show up if I try and ping it either.

My set-up Single Box Dev Machine SharePoint 2010 Enterprise SP1

I've googled some of the typical fixes and would like to use this as an educational piece too, hence my asking it here. I'd like to pick up things such aswhy does this happen and how can I avoid it in the future.

Many thanks,

  • If your new site has port number, make sure you are including 'http://' while typing url of your site in address bar of IE. – Amit Bhagat Sep 12 '13 at 13:29
  • Hi Amit, Thanks for your response. I've tried this, both with the IP and the host header. Both gave me the same error message. – Steven D Andrews Sep 12 '13 at 13:39
  • Did you provided host header ? – Pushpendra Sep 12 '13 at 13:50
  • Just for sure, check if site collection is really there. Go to Central Admin > Application Mangement (on the left) > View All Site Collections. – Amit Bhagat Sep 12 '13 at 13:57
  • Host Header was specified within the Web App Creation, if that's what you mean? Tried using it in IE with/without the port, didn't resolve. – Steven D Andrews Sep 12 '13 at 13:58
1

Open the IIS manager

Make sure the website is not stopped and running. Click on the website and right click

Manage Website > Start

OR

Check the app pool is running.

Application Pools in IIS Manager

  • Done both of these. The site in IIS has been (re)started and the application pool is up and running. – Steven D Andrews Sep 12 '13 at 13:40
  • I did not mean to restart but just to check if it is start and not stop – Amit Bhagat Sep 12 '13 at 14:41
0

Have you given a host header while creating the site collection. if yes then probably your IIS is not able to map it , to make it work you will have to make entry into the host file IP/Host Header pair and then it should work.

  • Hi Vishal, I was considering the hosts file but I'm thinking that this is normally seen as bad practice? – Steven D Andrews Sep 12 '13 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.