2

I have a SharePoint 2010 List with a simple Choice column called "RequestType" with values like New Hire, Job Change, Equipment Request, etc.

I can add the new records and select any option, but when I edit an existing record and change the "Request Type" value (let's say New Hire -> Job Change) and attempt to save the record, I am getting a

System.ArgumentException:Column '/dsQueryResponse/Rows/Row/@RequestType' does not exist.

I've verified the form field references, refreshed the datasouce in the form, and tried just about everything.

Here's the field Definition in the form:

<td class="overFieldLbl">
<nobr>Request Type<span class="ms-formvalidation"> *</span></nobr>
<SharePoint:FormField runat="server" id="ff24{$Pos}" controlmode="Edit" fieldname="RequestType" __designer:bind="{ddwrt:DataBind('u',concat('ff24',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),**'/dsQueryResponse/Rows/Row/@RequestType'**)}" />
</td>

Here's the datsource:

<DataSources>
    <SharePoint:SPDataSource runat="server" DataSourceMode="ListItem" SelectCommand="&lt;View&gt;&lt;Query&gt;&lt;Where&gt;&lt;Eq&gt;&lt;FieldRef Name=&quot;ContentType&quot;/&gt;&lt;Value Type=&quot;Text&quot;&gt;Item&lt;/Value&gt;&lt;/Eq&gt;&lt;/Where&gt;&lt;/Query&gt;&lt;/View&gt;" UseInternalName="True" UseServerDataFormat="True"><SelectParameters><WebPartPages:DataFormParameter ParameterKey="ListItemId" PropertyName="ParameterValues" DefaultValue="0" Name="ListItemId"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="weburl" PropertyName="ParameterValues" DefaultValue="http://vm-moss01-test/operations/NOPA" Name="weburl"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="ListID" PropertyName="ParameterValues" DefaultValue="{CA8714CD-FE01-4FA7-9B50-C06EB72BDE10}" Name="ListID"></WebPartPages:DataFormParameter>
    </SelectParameters><UpdateParameters><WebPartPages:DataFormParameter ParameterKey="ListItemId" PropertyName="ParameterValues" DefaultValue="0" Name="ListItemId"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="weburl" PropertyName="ParameterValues" DefaultValue="http://vm-moss01-test/operations/NOPA" Name="weburl"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="ListID" PropertyName="ParameterValues" DefaultValue="{CA8714CD-FE01-4FA7-9B50-C06EB72BDE10}" Name="ListID"></WebPartPages:DataFormParameter>
    </UpdateParameters><InsertParameters><WebPartPages:DataFormParameter ParameterKey="ListItemId" PropertyName="ParameterValues" DefaultValue="0" Name="ListItemId"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="weburl" PropertyName="ParameterValues" DefaultValue="http://vm-moss01-test/operations/NOPA" Name="weburl"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="ListID" PropertyName="ParameterValues" DefaultValue="{CA8714CD-FE01-4FA7-9B50-C06EB72BDE10}" Name="ListID"></WebPartPages:DataFormParameter>
    </InsertParameters><DeleteParameters><WebPartPages:DataFormParameter ParameterKey="ListItemId" PropertyName="ParameterValues" DefaultValue="0" Name="ListItemId"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="weburl" PropertyName="ParameterValues" DefaultValue="http://vm-moss01-test/operations/NOPA" Name="weburl"></WebPartPages:DataFormParameter><WebPartPages:DataFormParameter ParameterKey="ListID" PropertyName="ParameterValues" DefaultValue="{CA8714CD-FE01-4FA7-9B50-C06EB72BDE10}" Name="ListID"></WebPartPages:DataFormParameter>
</DeleteParameters>
</SharePoint:SPDataSource>
</DataSources>

And the dataFormWebPart Datafields:

<DataFields>
@Title,EmployeeID;@RequestID,RequestID;@RequestType,RequestType**;@FirstName,FirstName;@MiddleName,MiddleName;@LastName,LastName;@EmplStartDate,EmplStartDate;@EmplJobTitle,EmplJobTitle;@CCSites,EmplSite;@CCDepartments,EmplDepartments;@CCTeams,EmplTeam;@EmplSupervisor,EmplSupervisor;@ClonedEmployee,ClonedEmployee;@CitrixRequired,EmplCitrixReqd;@EmployeeMedManPrtr,EmployeeMedManPrtr;@EMR_Access,EmplEMR_Access;@EmplClinicalApps,EmplClinicalApps;@EmplFinancialApps,EmplFinancialApps;@EmplTransportApps,EmplTransportApps;@EmplSecMaintApps,EmplSecMaintApps;@EmplDimentiaAccess,EmplDimentiaAccess;@EmplDataCenterAccess,EmplDataCenterAccess;@EmplCCHPTraining,EmplCCHPTraining;@EmplFCTraining,EmplFCTraining;@EmplJobTitle_x003a__x0020_JobTit,EmplJobTitle: JobTitle;@CCDepartments_x003a__x0020_Depar,CCDepartments: Department;@ClonedEmployee_x003a__x0020_Firs,ClonedEmployee: FirstName;@EmployeeMedManPrtr_x003a__x0020_,EmployeeMedManPrtr: MakeModel;@EmployeeMedManPrtr_x003a__x0020_0,EmployeeMedManPrtr: PrinterLocation;@Author,Requestor;@ID,ID;@ContentType,Content Type;@Modified,Modified;@Created,Created;@Editor,Modified By;@_UIVersionString,Version;@Attachments,Attachments;@File_x0020_Type,File Type;@FileLeafRef,Name (for use in forms);@FileDirRef,Path;@FSObjType,Item Type;@_HasCopyDestinations,Has Copy Destinations;@_CopySource,Copy Source;@ContentTypeId,Content Type ID;@_ModerationStatus,Approval Status;@_UIVersion,UI Version;@Created_x0020_Date,Created;@FileRef,URL Path;@ItemChildCount,Item Child Count;@FolderChildCount,Folder Child Count;</DataFields>

I'd certainly appreciate it if anyone can point me to the error or how to find it?

  • Can you set the last part of your first code block to '@RequestType' only? – Eric Alexander Sep 11 '13 at 18:50
  • This was a silly mistake. I needed to update the data sources in the aspx page. Apparently there were changes to the list configuration after the form was generated. The easiest way to accomplish this was to create a new edit form. Then I copied the <DataSources> and <Datafields> tags content from the new form to the one giving me problems. That worked like a dream. – Daniel Kline Sep 24 '13 at 16:12
1

This was a silly mistake. I needed to update the data sources in the aspx page. Apparently there were changes to the list configuration after the form was generated. The easiest way to accomplish this was to create a new edit form. Then I copied the and tags content from the new form to the one giving me problems. That worked like a dream.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.