3

Please take a look at the following screenshot of my team site. I want to apply custom site layout on this team site. I opened the site in SharePoint Designer and made of copy of seattle.master and saved it as mysite.master. Then I refreshed the page as shown in screenshot but mysite is still not visible in the drop down menu of site layout.

How do I do that?

enter image description here

3

when you say you saved it as mysite.master, did you add the file by uploading it to sharepoint Master Page Gallery? once uploaded did you publish on the Master Page Gallery?

Site Settings -> Master pages and page layouts

now you can click the upload button to upload your mysite.master file,

othewise you can map your drive which makes your life alot easier!!

Map a network drive to the SharePoint 2013 Master Page Gallery

http://msdn.microsoft.com/en-us/library/jj733519.aspx

full masterpage edit

http://msdn.microsoft.com/en-us/library/dn205273.aspx

for further reading:

How to: Apply a master page to a site in SharePoint 2013

http://msdn.microsoft.com/en-us/library/jj862339.aspx

if thats too confusing follow these step by step guide on 2013:

http://blogs.technet.com/b/tothesharepoint/archive/2013/04/03/stage-6-upload-and-apply-a-new-master-page-to-a-publishing-site.aspx

EDIT

now i know you have that than you must be missing an active feature that you havent enabled for custom layouts:

Do you have MOSS or WSS? Because if you have WSS you can't create page layouts. Page layouts are a specific function of MOSS that is enabled when the publishing feature is activated. If you have MOSS you can enable publishing on the site. To enable publishing on a MOSS Team Site you'd have to do the following:

1) Click Site Actions > Site Settings from the top level site in the site collection

2) In the right column called Site Collection Administration click on Site collection features (if you aren't a site collection admin you won't be able to do this)

3) Find the option for Office SharePoint Server Publishing Infrastructure (or something close to that) and click to activate the feature.

4) Once the publishing infrastructure has been activated on the site collection you'll need to activate it for the site itself. To do that go to Site Actions > Site Settings and click on Site features in the site adminstration section (should be 2nd from the right).

5) Find the option for Office SharePoint Server Publishing and click to activate the feature.

Pubishing will now be enabled and you can create custom layouts on this site with SPD. However, like I said if you don't have MOSS all you'll be able to do is create pages. You can style pages similar to page layouts, but from a functionality perspective they are very different.

  • Yes my master page is available in Site Settings --> Master Page Gallery but there is no Page Layout option there probably because this is a team site and not publishing site. – Frank Martin Sep 10 '13 at 9:49
  • just ammended my answer – Ali Jafer Sep 10 '13 at 13:06
  • No I don't want to enable publishing feature on Team Site. I want to change its page layout or let's just say master page so that my publishing site and team site has same header and footer. Can I do that without enable publishing feature? – Frank Martin Sep 11 '13 at 7:21
  • Hi Frank, Did you get solution for this.. I also have same requirement – user9167 Jan 30 '14 at 6:01
0

I had the same problem. You should change it under Site Settings --> Master Page. Maybe you have no layout for this page. If you have an aspx file where the custom layout is located, Go to Site Setting , Master pages and page layouts and under files click upload document. After you upload another window will pop up. When it asks you about the content type you should choose page layout. Scroll down and for Content Type group choose Page Layout Content Types. For content type name choose Article Page. Click save. Choose file and under file options choose publish a major version. You will be able to see the page layout now. To change the page layout go to Edit page , Page , Change layout.

In some cases Change Layout Option will not show up. If it doesn't your page is not a publishing page. I suggest you create a publishing page for it. Here is a tutorial in how to change the theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.