0

I have bunch of user in a SharePoint group with Special Contribute access (same as contribute permission but No delete).

These users are not seeing "Edit in Microsoft Excel" in the ECB menu. If I log in with service account (who is site collection admin) then I see the "edit in microsoft excel".

enter image description here

  • so anyone wana take a stab at this? – Jennifer Hudson Sep 9 '13 at 19:59
1

Jennifer,

After messing around with a modified permissions level of Contribute access (without delete), I've come to notice that the "Open Items - View the source of documents with server-side file handlers." permission must be checked in order for the users with that permission level to see the "Edit in Excel" button on the ECB menu.

Another possible reason could be that the file has unique permissions and the user group somehow got marked with "View Only" access to the file.

Those are the only two ways I was able to recreate the issue.

0

Turns out is not about the permissions. I read this article http://blog.karstein-consulting.com/2011/01/22/missing-view-in-browser-and-edit-in-browser-in-the-context-menu-of-excel-files-in-a-sharepoint-2010-document-library. I then uploaded an excel file that was created in Office 2010 and uploaded in the same library. Now I see the "Edit in Microsoft Excel" for this newly added item. However, the old item (which may be in non-open xml format) still does not give me "Open in Excel" option (which is okay). I rather know the fact what was the cause of this behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.