This shouldn't be hard, but ultimately is.

I only found references that I should backup the existing MySite and move it to another location. The MSDN documentation on Configure My Sites in SharePoint Server 2013 is pretty thin on changing the URL.

The only viable information I found so far is: UserProfileManager.MySiteHostUrl (gets or sets the URL for the current context). Under User Profile Administration > Setup My Sites I am also supposed to be able to change the My Site URL.

The problem is that none of these changes are persistent. I change the MySitehostUrl with PowerShell - the change is not persisted. I change the URL via CA, click OK, the URL is gone.

I initially set up MySites to not use HTTPS, I want to change that now. AAM is set up and HTTPS works perfectly, only the URL is still wrong.

How to change the MySite Url from: http://mysite.example.org to https://mysite.example.org?

1 Answer 1


When you changed the My Site Host URL did you extend and map it to your original my site host or did you just add the binding in IIS and then change AAM? Change the web application and ensure that all of the dependancies are working as well as changing the setting in the User Profile Service Application.

Ensure that the URL you wish to use for the MySite Host URL is in the DEFAULT zone in the AAM Mapping.

Once that is done it should work just fine.

  • Ah, I think you're right with that. I only changed the IIS binding and added a certificate. So you're saying I should just extend the web app, then I should be able to change the URL?
    – Dennis G
    Commented Sep 13, 2013 at 6:16
  • 1
    Yes, the "right" way is to extend the web app and then handle the certificate on the new site. Commented Sep 15, 2013 at 20:36
  • I extended the Web Application now, still I cannot change the MySite Host URL. Again: It is accessible via the URL - I'm talking about the MySiteHostUrl: msdn.microsoft.com/en-us/library/… - I believe this relates to the Host URL Setting in the UPS - changing it there has no effect either, it is just not saved.
    – Dennis G
    Commented Sep 16, 2013 at 8:39
  • Are you monitoring the ULS logs while you are changing the URL? Commented Sep 16, 2013 at 14:40
  • Good thinking. Nothing out of the ordinary. No exceptions.
    – Dennis G
    Commented Sep 16, 2013 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.