Solutions tried so far:

A common cause of this error is that the service account running the Management Reporter Process Service does not have the Design permission on the SharePoint library

Remove the invalid characters from the report's Output name per the SharePoint requirements

Under Document Library Settings and Advanced Settings set "Allow Management of Content Types" from no to yes

Under Content Types in your Document Library Settings page click on "Add from Existing Content Types" and add the "Link to Document" content type

Security Configuration section, click Blocked file types from Central admin link, and Remove the "Url" type in the list (Only if exists)

Install Desktop experience services, restarted machine and tried to publish the report link. Also checked running services like Computer browser and WebClient and its running fine.

Still its giving me error says: Unable to create the related report link. Any help appreciated very much.

Thanks, Bhavin

1 Answer 1


go to the SQL server MR uses, launch MR configuration console, check Management Report Process Service, the service account has to have Designer permission in that SP library.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.