1

I have setup sharepoint search server for my website and the site crawling was ok. I did a full crawl recently and its not getting crawled properly. I have nearly 3000 pages on my website, only half of the web pages got crawled properly. When I check the "crawl log" for half of the pages shows as "deleted by the gatherer"

Please let me know what could be the reason as this suddenly happened.

1 Answer 1

2

This error can occur if you're having multiple crawls that occur at the same time. It may lead to a collision with the results getting put into the search index. If this happens too often the content will be removed as being unseen. There is a three day limit on keeping results and if the content is not found again within that time then it will be removed.

As an example the content and the people queries may be running at the same time, then adjust the schedules and doing some restarts of the services and see if the content being collected in the search index again.

You may need to reset the search index, before you do a full crawl to get you content back in the index. To do that, follow the steps in the article Reset the content index (SharePoint Server 2010):

To reset the content index

  1. Verify that the user account that is performing this procedure is a service application administrator for the Search service application for which you want to reset the content index.
  2. On the SharePoint Central Administration home page, in the Application Management section, click Manage service applications.
  3. On the Manage Search Applications page, click the Search service application for which you want to reset the content index.
  4. On the Search Service Application: Search Administration page, in the Quick Launch, in the Crawling section, click Index Reset.
  5. On the Search Service Application: Index Reset page, verify that the Deactivate search alerts during reset check box is checked, and then click Reset Now.
  6. In the confirmation dialog box that appears, click OK to confirm the content index reset.
    • The Search Service Application: Search Administration page opens and the System Status is displayed.
  7. Perform a full crawl.

Reference: Deleted by the gatherer messages in the Crawl Log?

9
  • Thank Benny!! Actually I saw this post when I was searching on Google. In my search server there was a another website and I stooped the crawling of that website and I have only this website I restated the server and did a full crawl again but no luck ! Sep 4, 2013 at 12:42
  • @prasannapeiris Great! Have you finished the full crawl and gotten your content back in the crawl index?
    – Benny Skogberg
    Sep 4, 2013 at 12:44
  • No Benny, still not, when I check the crawl log most of the pages it shows as "Deleted by the gatherer" Sep 4, 2013 at 12:48
  • @prasannapeiris Have you cleared the search index, before you started the full crawl?
    – Benny Skogberg
    Sep 4, 2013 at 12:49
  • No I didn't how do I do it? I am very new to this environment. Please help! Sep 4, 2013 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.