3

When i create a content editor web part on a publishing page in SharePoint 2010, the following code is created:

<div WebPartID="151e7c56-689b-48ef-ab7e-7f8ed3958cb5" 
    HasPers="false" 
    id="WebPartWPQ1" 
    width="100%" 
    class="ms-WPBody noindex ms-wpContentDivSpace" 
    allowDelete="false" 
    style="" >

Why is the "noindex" CSS class present? Does this prevent the content from being indexed by a crawler? How can I remove this attribute?

  • 1
    Generally speaking, you shouldn't be using content editor web parts in publishing pages for content, that's what the field controls are for in the page layout. – Eric Alexander Sep 3 '13 at 17:55
  • No argument there, @PirateEric. Nevertheless... – Markus Sep 3 '13 at 19:46
1

Turns out it is a site setting.

http://office.microsoft.com/en-us/sharepoint-server-help/enable-content-to-be-searchable-HA010379092.aspx#_Toc355013924

  1. Navigate to the site for which you want to control the Web Parts in search results.
  2. Click Site Actions, and then click Site Settings.
  3. Under Site Administration, click Search and offline availability.
  4. In the Indexing ASPX Page Content section, checked to Always index all Web Parts on this site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.