0

We are using SP2013 for a public facing internet site, which entails turning on anonymous access and using publishing sites. The problem is we have internal users who add content to the site and they may forget to publish a referenced image in the content of a page. When an anonymous user goes to view said page they get an auth prompt for the image.

This seems a gaping hole for a product that is supposed to support public facing internet sites. My question is how can SharePoint be configured to never auth prompt for unpublished images?

1

Disable content approval on the library that holds the images.

It isn't a gaping hole, it's users aren't properly following the procedure in a publishing environment with content approval.

  • 1
    Content approval is disabled and it still auth prompts for any referenced images which don't have any published version. I believe this is a gaping hole because you cannot expect users who are editing pages and adding images in the process to always remember to go back and publish images. It would be nice if when they hit publish on a page it auto published all related assets. – James Sep 3 '13 at 16:52
0

I recently ran into this problem as well.

Go to the properties of the library holding the image/document. In versioning settings change the "Draft Item Security" to "Any user who can read items".

The problem was the image I had was a "draft" image. To fix it just check it out and check it in as a major version (published).

Hope this helps someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.