1

I am creating a Search scope For fetching a Document library in my site. Below are the steps which I have tried:

  1. SiteActions-->SiteSettings-->SiteCollectionAdministration-->SearchScope.
  2. Clicked on NewScope.
  3. Provided the Title and Clicked on Ok.
  4. Clicked on Create Rule.
  5. http://abc.com/sites/MySiteCollection/_layouts/viewlsts.aspx?BaseType=1
  6. Clicked ok.

After 10 minutes the resuilts displayed is 0. I have 15 Document libraries Listed when I navigate to http://abc.com/sites/MySiteCollection/_layouts/viewlsts.aspx?BaseType=1.

Can you please let me know what is wrong with my search scope?

  • have you tried to just create different parameters to the search? add to the "Search Here" drop down menu? Your searching inside the libraries or for the libraries themselves? how many libraries do you have? – user35107 Nov 12 '14 at 13:48
1

Use URL of your document library, not the URL of your view. For instance, if your library is "MyDocumentLibrary", select "folder" in SearchScopeRule and use address like this http://www.abc1.com/sites/MyDocumentLibrary/

Hope this helps you.

|improve this answer|||||
  • Thanks for your reply. Basically I want to Include All document Libraries and Search for a Particular Document Library. So i have Modified my Rule as Below (ContentClass=STS_List_DocumentLibrary). But How should i use this Search Scope in my Page.?Can you please help me on this – santosh kondapalli Sep 4 '13 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.