Worked with my infrastructure admin today to configure my 2013 farm to be load balanced on our netscaler...I have two WFEs that i'm using. There are three web applications that i use in this farm, one for content, search center and mysites. Prior to configuration the farm was configured for HTTP, when we load balanced it the idea was to offload SSL, so that the balancers would handle the process rather than the WFE.

The load balancer was setup so that if a request for a web application was in HTTP it would switch them to HTTPS. I was under the impression that i could leave the environment in HTTP mode, that the load balancer would create the secure session and the client would only see HTTPS but the communication between the load balancer and the WFE would be HTTP.

The load balancer was configured to respond to one ip address for all three web applications, my understanding as i was told was that whenever that web application was called...it would point to the IP address assigned to the load balancer then the traffic would be directed properly.

Here is the problem, when i attempt to access the web application example...http://webapp1.company.com, it does the HTTPS redirect and the URL changes to https://webapp1.company.com, but i'm now prompted for my login credentials and when i enter them it continues to prompt me...as if it cannot authenticate me. Before the load balancer configuration was put in place, i did not have to provide credentials...the web applications are setup to use negotiate NTLM/Kerberos.

Is there something i'm missing in my configuration of my farm that is causing this problem? do i actually need to have the web application setup in HTTPS mode instead of HTTP to get this to work? thus having to load the certificate on the WFE? i thought that by putting it through the load balancer that this would not require me to manage certificates on my WFEs.

  • Have you tried just adding the domain into the alternate access mapping? This may be enough to trick SP into thinking it's loading it correctly. Commented Aug 28, 2013 at 20:53
  • at first i didn't have any AAM set...i found a guide that talked about how to configure the AAM's and followed it...so essentially my AAm is configured "webapp1.company.com" (internal) default (zone) webapp1.company.com (public) then webapp1.company.com (internal) default (zone) webapp1.company.com (public). This did not make a difference either....still prompting me for credentials...i dont have to have the web application created as SSL do i? i can leave it HTTP and leverage the load balancer for SSL?
    – Jacob A
    Commented Aug 29, 2013 at 1:11
  • Here is the link to the article i found..... onpointwithsharepoint.wordpress.com/2013/02/19/…
    – Jacob A
    Commented Aug 29, 2013 at 1:13
  • configured https//webapp1.company.com; (internal) default (zone) https//webapp1.company.com (public) then http//webapp1.company.com (internal) default (zone) https//webapp1.company.com (public).
    – Jacob A
    Commented Aug 29, 2013 at 1:17
  • I assume this didn't work? Commented Aug 29, 2013 at 11:39

1 Answer 1


Found the problem!

Worked with the Admin who configured the load balancer, explained what was going on and how a non HTTPS web application experienced the same issue.

He found that the configuration on the netscaler was set to keep cookie persitance to 2 minutes, he set it to 0 effectivly expiring it when the browser session closed and that resolved the problem for some reason...still not sure how that played a role in it but once he made the adjustment it started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.