3

I have a problem in SharePoint 2010 where if I'm creating a SPD workflow to a list, that just has it run automatically and log "Hi" in the history list, it won't 'run' because the files show as Checked Out in SPD All Files, Workflows, "my workflow" folder.

I can't figure out how to recover.

When I try to force Check In, I get

"Cannot perform this operation. the file is no longer checked out or has been deleted".

When I try to Undo Check Out, it says

"Server error: you cannot discard check out because there is no checked in version of the document. please delete this document instead".

When I try to look at Version History, it says that the file is saved to a web address as shown in the picture, but clicking on the link gives a 404 error:

enter image description here

4

We had this problem once and it was because someone had set Title to Required in the OOTB Document Content type. FWIW, SharePoint stores Workflows in a hidden document library. If Title is required, the workflow "file" will remain checked out in the Workflow Library since SharePoint doesn't give Workflow Files Titles. The fix was to change Title back to optional in the OOTB Document content type. One more lesson why you should never change the OOTB content types, but instead make a copy for your own uses. :)

1

I had to completely rebuild the site to another site and migrate all the data. Horrible pain. I worked with Microsoft on this for 1.5 months to no avail.

1

A huge thank you to @TashasEv for that answer. I was having the same problem for days and couldn't figure it out, but your answer set me on the correct path.

Here's was our problem - whenever a workflow would run, we would get an error saying that the workflow failed to run, and "Workflow canceled by System Account."

As I went deeper into the workflow files themselves, I was seeing that some, but not all of them, were checked out. I tried to check them in. I received the exact same error you did about not being able to check the file in. I checked the ULS log around the time I attempted to check in the file and got this:

SOAP exception: System.Runtime.InteropServices.COMException (0x82000009): You must fill out all required properties before checking in this document.     
at Microsoft.SharePoint.SoapServer.ListDataImpl.CheckInFile(String pageUrl, String comment, String CheckinType)    
at Microsoft.SharePoint.SoapServer.ListDataValidatorImpl.CheckInFile(String pageUrl, String comment, String CheckinType)     
at Microsoft.SharePoint.SoapServer.Lists.CheckInFile(String pageUrl, String comment, String CheckinType)

Fun!

I then looked at the content types and compared them to see what was different between my site and another site which was working. Sure enough, there's a column called Client which was set to Required in my User Workflow Document content type which should have been set to Optional. I made the switch, was able to check in the workflow files, and my workflows started working.

A note on the User Workflow Document content type. It is a hidden (seriously!??) content type, so you won't see it unless you open SPD, click "All Files" on navigation, then right-click the "Workflows" special folder and click "Properties". From there, you can look in the Content Types section and right-click to edit the User Workflow Document content type. You'll need to go to the individual column's Administration Web Page to set the properties.

PS. I hate SharePoint.

1

I also would like to thank TashasEv for his answer. It provided the key clue I needed for troubleshooting a similar problem. In my case, it was not the Document content type which had the title set to Required, but the User Workflow Document content type. This is one of two content types that are shown listed when (in SPD) you right-click on the Workflows folder in the left Navigation panel (the other being Folder). I used the Administration Web Page (it's a button in SPD when on the Properties tab for the Workflows folder). Changing the Title property of this content type to Optional solved the issue.

0

You little beauty, the only article that actually described how to fix it. Seems the hidden number was indeed hidden away and doing the below is the only way to access it -

Go to Workflows in All files > at bottom go to User Workflow document, then edit content type, then admin web page. Then go check the files in.

  • please explain it in more detail, not able to get the point – Amay Kulkarni Jul 28 '16 at 9:11
0

My situation was slightly different. I tried the other solutions and it hadn't helped me but it did expose my problem.

The files that were causing the above errors were files I had imported manually into the folder. By doing this, SharePoint named the files' titles to "path/path/filename.ext"

Titles cannot have the "/" which was throwing the error. I manually replaced the files' auto-filled titles without the "/" by right-clicking the files -> properties. Worked like a charm afterwards.

0

Thank you, it's working for me (the column Title was renamed by Summary, thanks dev team who edited an OOTB column and set it to Required):

$Web = Get-SPWeb https://WEBSITE
$List = $Web.lists["Workflows"]
$f = $List.Fields["Summary"]
$f.Required = $false
$f.Update()

You need to recreate your workflow

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.