2

I am having a problem upgrading my local SharePoint 2010 Development environment. I recently installed Service Pack 2 for SharePoint 2010 (KB2687453) and the SharePoint 2010 Cumulative Update Package (KB2817527). Upon successful completion of the two updates, I've tried running the SharePoint 2010 Products Configuration wizard multiple times.

The error I receive is:

Failed to initialize the upgrade sequence.

An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown. Additional exception information: Exception of type "Microsoft.SharePoint.Upgrade.SPUpgradeException" was thrown.

This wasn't too much to go on but I started Googling and looking around. I found a lot of articles telling me to check the SharePoint Health Analyzer for errors. I did and I found a long list of MissingWebPart, MissingSetupFile and MissingFeature errors. I've worked several days on resolving all of these issues. They have all since been resolved. However I run the Configuration Wizard and it continues to return the same error.

I was wondering if anyone had any ideas?

I have a log file if anyone would like to view it. It's long though so it is not included in this post. I've sifted through it but not really found anything useful except:

Task upgradebootstrap has stopped and failed. Total failed is now 1

Last message from task upgradebootstrap is An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown. Additional exception information: Exception of type 'Microsoft.SharePoint.Upgrade.SPUpgradeException' was thrown.

Just as a reference, I'm running SharePoint 2010 on a Windows Server 2008 R2 environment.

1

My issue was that I was missing this Microsoft Download, installed and voila!

http://go.microsoft.com/fwlink/?LinkID=122517

  • Thanks for the post. Unfortunately it did not work. I do appreciate your time though. – War10ck Dec 5 '13 at 15:50
  • Did you uninstalled the Internet Infomation services from optionalfeatures, restarted and installed the whole branch of Internet information services from optional features again? – Alfonso Leon Dec 5 '13 at 17:12
-1

Looking at the upgrade log a little more closely, I found this error.

Upgrade Timer job is exiting due to exception: System.ArgumentException: localStoragePath

Right before that line, it was working on the search DB, so I ended up finding this article and removed the SSA, and then the upgrade worked great.

http://blog.bugrapostaci.com/tag/localstoragepath/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.