I am having a strange issue with one of my Document Libraries. It is the document library created by the publishing feature "Documents." Here are the symptomps and what I have done so far. Any help would be greatly appreciated:


  1. Update existing item field >> Save and close item >> re-open item. Field not updated, but Modified By and Modified Date updated for the item.
  2. Create a new item >> Save item >> repeat same steps as for existing item >> works as expected.
  3. (Update) Tried to update the document property from Microsoft Word (File > Properties) >> This works as expected.

What I have done so far:

  1. Added a new field (of Enterprise Metadata type) to the list >> repeated the steps listed under Symptoms >> no change.
  2. Checked ULS activity when updating item >> got the entries as listed in this website: http://www.deviantpoint.com/category/NET.aspx. As for the solution listed there, removing the <trace> element, could not find that element in my web.config.
  3. Updated the list item programmatically >> same results as if modifying manually.
  4. (Updated) Removed the workflow attached to the list. This workflow used to get activated when a new item was create or modified >> same results - no change.
  5. (Updated) Ran the following PowerShell commands to get the lists and event receivers attached to the lists. Result for the Documents library below:

    $web = Get-SPWeb -Identity "http://subsite/url"
    $web.Lists | Where {$_.eventreceivers.count -gt 0} | Select title,eventreceivers | Format-List

    Title : Documents EventReceivers : {, , }

  6. (Updated) Opened the MS Word document in one of the items >> File menu >> Info side tab >> Check for Issues >> Inspect document. Document inspector returned with Document Properties and Personal Information (Document properties, Author, Related documents and path, Document server properties, Content type information), and Custom XML Data. I then clicked on the "Remove All" buttons for removing the Document properties and personal information and Custom XML Data >> Saved the document >> Edited the document. This time it worked! This at the expense of some of the metadata associated with the document. Is there any way of telling why this may be happening? Or is there a way to pin point which metadata is causing problem?
    (Updated II) I removed the Custom XML Data from another document in the library the same way. Now, all the items are magically updating after edit and saving properly. How did this happen?

I am at the end of my wits with this issue since there is no debug information, nor can I link this behavior with a particular event. Please help.

  • 2
    Are any event receivers registered to the list? There's some powershell here to check: techtrainingnotes.blogspot.ca/2011/06/…
    – lgaud
    Aug 26, 2013 at 18:18
  • No event receivers; however, there is a workflow attached. I have 'deactivated' the workflow. It used to get set off when item was created or edited. I removed those triggers including the possibility to manually start it. I will look into the powershell scripts though. Thank you.
    – Tom
    Aug 26, 2013 at 18:30
  • @Igaud I think we are on to something. Running the powershell script on the RootWeb showed EventReceivers attached to the Documents library; howerver, for the misbehaving Documents library, it returns three empty slots.
    – Tom
    Aug 26, 2013 at 18:44
  • Tom, is your default edit form a custom form or the one created with the list? I ask because sometime the binding on some fields get created incorrectly for custom forms. Aug 27, 2013 at 19:19
  • @T0t3sMcG0t3s I am not sure if it is default. I was not able to find the Edit Form button on the ribbon as with the other lists. Instead there is Form Webparts.
    – Tom
    Aug 27, 2013 at 19:30

1 Answer 1


If the field is somehow registered in the list as a Read-Only field then it would behave exactly like this. An easy way to tell is to simply edit the properties for an item in the list. If the field is not editable or not visible on the edit form then this is what you are hitting.

  • Hi Dave, Thank you for your response. Unfortunately, the fields are perfectly editable from the UI as well. Also, if I create a new item, all fields save normally.
    – Tom
    Aug 26, 2013 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.