1

I am uploading documents to a document library in SharePoint 2010 and I find my documents are checked out even they are not checked out. I have checked for option check out required to NO but even the problem doesn't go. Does anyone know the solution for this?

  • What method are you using to upload? – BlueBird Aug 22 '13 at 14:02

10 Answers 10

1

I just encountered that in one of our sites. Management of Content Types was not allowed and the Title field was required. I could not make changes to the Title field in the library settings, so I had to allow management of Content Types, go into the Content Type, click on the Title Field, and edit the setting there. I chose "hidden" rather than optional, which serves our purposes. I then switched the Content Type settings off. You may need to dig deep into your library to solve it if the other options listed do not work.

  • This does not solve the issue, nor do any of the others below. – Shackrock Aug 31 '16 at 20:56
  • What happens if you leave "Management of Content Types" set to "yes"? – Andrea Pasutti Sep 6 '16 at 20:14
  • Same effect, it appears I have a required field 'name' which is not editable by me. It seems the system requires it no matter what? – Shackrock Sep 6 '16 at 20:16
2

Set “Require documents to be checked out before they can be edited” to “No” and make sure all required fields have a defaul value.

If you need the check-in / check-out functionality you will need a non-OOB solution.

  • I think the question is asking how to keep that option enabled, and still be able to be checked in automatically on first upload. – Shackrock Aug 31 '16 at 20:56
1

Right-Click the document, view properties, if any of those fields are empty, try deleting them

0

I had a similar problem with multi-upload. All files were checked out after uploading them. I used an eventreceiver to force check in after upload.

  • 2
    Maybe, you have to take a look at empty required fields, too. – Stefan Hennicken Aug 22 '13 at 14:10
  • Hi Stefan Thanks for response but in my case i don't have any required fields .But my documents are attached with a workflow .I have checked my workflow as well but no issues there.Any other idea? – SPLearner Aug 22 '13 at 14:22
  • Are you using multi-upload? – Stefan Hennicken Aug 22 '13 at 14:25
  • No i am not using – SPLearner Aug 22 '13 at 14:31
  • Can you provide details on how to set this up? – Shackrock Aug 31 '16 at 20:57
0

I had the same problem. My problem was that I had made my "version column" a required field. You can check it in library settings.

0

For me it was the "Description" value, which wasn't set in any of the copied documents, but was mandatory in SharePoint. I solved by setting a default value for "Description" (I put a "0"). Go to LibrarySettings>Column default value settings and put a default value there.

0

I had the same problem, too. To compile the answers of Phil, Alexandru and Stefan:

I realised that the reason my newly uploaded files were checked out is because I uploaded them using multiple uploads, while I have some properties which are required to be filled in for every file. To comply, SP checked them out by default. I couldn't check them in without adding the appropriate property content first. So I added the properties, then checked them in.

0

This problems occurs because if any of the content type has required fields and donot containe default value. the document is automatically checked out. Remove the required fields in all content types and upload it will definelty works.

  • Does not work for me. Still have the issue. – Shackrock Aug 31 '16 at 20:41
0

I know this is an old thread, but here is what I did to solve the issue on my end. I went to http://example.com/15/LstSetng.aspx and clicked on Versioning Settings. I changed the values for the following 2 fields:

  1. Require content approval for submitted items? to No.

  2. Require documents to be checked out before they can be edited? to No.

The above steps did help solve the issue of uploaded documents being checked-out automatically.

Thanks,

0

I had a data validation rule in place for my End Date field > Start Date so multiple uploaded files were remaining checked out until I set the values of those dates.

protected by Mohamed El-Qassas MVP Aug 23 '18 at 18:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.