0

I am getting a "Login failed for user " error when try to search on my SharePoint site. The site is loading fine, but its the search page thats throwing the error.

Event viewer info

Process information: Process ID: 3644 Process name: w3wp.exe Account name: "Application Pool Identity Account"

Exception information: Exception type: SqlException Exception message: Login failed for user "Application Pool Identity Account"

  • 1
    Can you try to manually give permission that account to SharePoint search database in SQL Server? – Amit Bhagat Aug 22 '13 at 3:42
  • I have checked the access to Search Database in SQL, the user is having proper rights. – Thomas Mathew Aug 22 '13 at 4:44
1

Sounds like the Application Pool Identity doesn't have access to the Search database in SQL Server. Check the permissions and if necessary, grant it the correct rights.

This TechNet forum thread has a little more information that you might find helpful. The article is about the profile database but you might find a little more information about your error.

Hope this helps!

  • I have checked the access to Search Database in SQL, the user is having proper rights. – Thomas Mathew Aug 22 '13 at 4:43
1

Can you try giving proper rights to all 4 Search Databases in your Search service.Search service uses 4 databases namely Administration,Analytics Reporting,Crawl Store and Links Store, you can find these each individual database names in Search Service Application in Central Admin.

0


The issue was with a web part (on that particular page) which had a connection string with SQL. The connection string (sql instance) was wrong. Correcting the instance resolved the issue.
Thanks for all your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.