0

I have an issue whereby users can't see the 'Modified By' or 'Created By' columns on my SharePoint site (the columns are blank).

This issue affects all users, even those with full control.

I've found a quick fix by going into Central Administration > Application Management > Policy for Web Application, then ensuring the users have the following permissions:

Manage Lists

View Items

Edit Items

View Items

View Pages

Open

Manage Personal Views

This however makes the site extremely slow for all users.

Does anyone know how to fix this please?

  • Go to the list and click the ... button and "Modify this view". Then you can add 'Modified By' and 'Created By' columns. – David Aug 21 '13 at 9:38
  • Hi David - the columns are there and can be seen it's just they're empty... – dawsonz Aug 21 '13 at 10:41
  • how do you grant access to the User Information List? – user21175 Dec 3 '13 at 20:17
1

Does the users has access to the user information list? In these column you should see the value of lookup field. This kind of field cannot display data that is not permitted for the user.

  • Hi Alexander - the users can't access the user information list. – dawsonz Aug 21 '13 at 13:59
1

I recently had the same issue, i found that in user informtion list settings --> Advanced Settings --> Item-level Permissions --> Read access:   Specify which items users are allowed to read, the second option was selected i.e., "Read items that were created by the user". I set it to "Read all items" and clicked on OK. This fixed the issue for everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.